Asus KCMA-D8

brand: |
model: |
bios: |
7e010c9 (Libreboot @ /stable/20160907/rom/grub/)
cpu: |
AMD Opteron™ Processor 4274 HE
cpu-short: |
Opteron 4274 (x2)
chipset: |
Advanced Micro Devices, Inc. [AMD/ATI] RD890 Northbridge only dual slot (2x8) PCI-e GFX Hydra part [1002:5a12] (rev 02)
chipset-short: |
gpu: |
Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn XT GL [FirePro W7000] [1002:6808] (prog-if 00 [VGA controller])
gpu-short: |
AMD FirePro W7000
network: |
Intel Corporation 82574L Gigabit Network Connection
Intel Corporation 82574L Gigabit Network Connection
memory: |
scsi: |
Samsung SSD 860 Rev: 4B6Q
usb: |
qubes: |
xen: |
kernel: |
remark: |
Nvidia GPUs tested: 750ti and 1060. These don’t work good with KCMA-D8. You can get them to work if you disable nouveau drivers, but then what’s the point? I think nouveau had problems with vesa handover or something. Both nvidia cards did work on qubes with a different mobo on a standard bios. Popped in an AMD GPU for KCMA-D8 and it works great.
Has issues with sys-usb not seeing usb controllers randomly. Currently using a ps/2 keyboard and usb mouse. I just reboot or try moving the mouse to a different usb port when it doesn’t work. Mouse seems to work reliably with an external usb hub, but I only just started using it.
credit: |
link: |

confusing libreboot comment

@Sven is first vintage Libreboot HCL report posted on forum?

Any troubleshooting tips for sys-usb randomly not seeing kcma-d8 usb controller? Is this known issue?

Thank you! Litter_Box for post and your workaround.

Edit: Moved reply to Kcma-d8 sys-usb working 50% of the time - #16 by Insurgo

Thank you @Litter_Box for your report, which is online now!

Sleep mode did not work for me. This thing heats up a small room.

Tried to run 2 GPUs at the same time:

AMD + Nvidia → Hang at Seabios
AMD + AMD → Hang at Seabios

Tried some CPU governor tweaks for Opteron 4274 HE:

Powersave → 1 minute to launch whonix-ws-16-dvm (1.4GHz)
Performance → 37 sec to launch whonix-ws-16-dvm (2.5GHz)
Ondemand → 43 sec to launch whonix-ws-16-dvm

1 Like

Setting the displays for “quick power off in blank only mode” under screensaver settings really cut down on the heat generated while leaving the computer to run overnight.

Installed the fastest Opteron supported by this board.

Tried some CPU governor tweaks for Opteron 4240:

Powersave → 62 sec to launch whonix-ws-16-dvm (1.4GHz)
Performance → 30 sec to launch whonix-ws-16-dvm (3.4GHz)
Ondemand → 37 sec to launch whonix-ws-16-dvm

1 Like

Upgraded from 64GB to 128GB of RAM and it runs fine.

1 Like

Do you know what the total power consumption is at 100% load?

Some power tests (measurements taken at AC input of power supply):

Using: Opteron 4240 CPU and AMD FirePro W7000 GPU

Testing parameters for 100% load: stress -c 12 (running in a debian dvm set to use 12 vCPUs)

Powered down → 2.5 Watts
Idle → 150 Watts
100% load → 330 Watts then crept up to 350 Watts


Thanks for the info, the 150w idle is brutal with the current electricity prices.

Energy consumption can vary greatly depending on the processors used. The ones I’m running are 95 watt processors and I’m running two of them. You can just run one of them and put a piece of plastic over the unused processor socket. There are lots of processor options out there. See: list of Opteron processors. Try finding a wattage that works for you. Libreboot for KCMA-D8 currently compatible with 4200 and 4300 series CPUs. See Libreboot. NOTE: KCMA-D8 currently unsupported by libreboot. Just download the older version of libreboot. See: Libreboot Bios download.


The dusk of civilization.

Computer got stuck at “loading initram” on powerup. Rebooted and works fine. This happens very rarely. On another note the USB hub still works great, still no usb mouse issues while using it. I’m using this usb hub. I don’t use the external power adapter for the hub.

With memory balancing turned off, VMs are very smooth. qmemman may not like the registered buffered ram or something.

Thanks for all this info. I came to this thread by searching for memory compatibility of this board. What memory modules are you using? All the same or different?

How stable is your system?
I have KGPE-D16 with 192GB ram and its pain to deal with it.

I don’t touch sleep mode because it doesn’t work. Computer boots fine about 95% of the time. It’s rock solid once it’s up and running. What problems are you having with yours?

I have 2 of the KCMA-D8 motherboards and each has the following RAM:

  • Samsung “Used” 128GB (8x16GB) DDR3 PC3-10600R ECC Reg RDIMM $144
  • A-TECH “New” 64GB (8x 8GB) DDR3 PC3-10600R ECC Reg RDIMM $120

The “used” RAM looked like new, I regret buying the “new” ones.

1 Like