AP Linux Standalone Qube

What are your virtualization and kernel setting on the standalone? Qubes Manager → (highlight VM) → settings → advanced tab

[edit: oops… weird. First time I loaded this page, only the first three messages loaded. Not sure my question is as relevant now]

Any help is appreciated, this is quite a frustrating point to be stuck at.

On the advanced tab all Memroy/CPU, other and Window options are standard/normal. Virtualization is set to HVM and Kernel WAS set to (none).

I just noticed that the Kernel setting has gone back to (current), if I select (none) click ‘ok’ and reopen the settings it has gone back to (current), the same thing happens if I change it and click ‘apply’…

@ppc are you able to tell me which option I should be selecting from the ‘Storage Pool’ list, is it the ‘Linux-kernel’ option?

This is the only option that won’t work for me, the qube isn’t created.

[edit: see next message]

Wait… I know what you did. You didn’t create an “empty standalone”. You created one based on a template. You are trying to start a template-based standalone with no kernel. You need to create a new standalone based on no template (simplest way is with the Qubes Manager GUI). Then set the kernel to none and the virtualization to HVM and increase the private disk size to accommodate the new OS.

Then, with your iso in another VM, start up your HVM from dom0 with:

qvm-start <HVM_VM> --cdrom=<VM_with_iso>:/path/to/installer.iso
1 Like

It seems that (current) is (none), a little embarrassed there…

@necker I was certain that I created the qube as a standalone with no template, but just to be sure I deleted it and started fresh.

Unfortunately I am certain this time, no template was selected and the problem is still the same, and I had even less luck trying to use the default kernel instead of none.

When you create the qube are you using the ‘Linux-kernel’ option in ‘Storage Pool’?

No… “default (vm pool)”. I use the GUI from Qubes Manager and leave all of the advanced tab settings in the default position.

I actually like the idea of a standalone audio qube… I’ll see if I can get it set up. It might be an issue with Qubes 4.1 Keep in mind we are using an experimental OS. If you have an extra machine to install 4.0.4, you might want to give that a try. I’ll post here later to let you know the results of my install attempt.

[edit: I have the standalone and AP Linux iso ready to go but I’m unsure about security risks. I don’t like downloading 2 year old iso files from SourceForge with nothing but an MD5 checksum offered by the same download source… especially when installing on an HVM. I’m going to hold off on AP Linux for now and try with a different iso.]

Okay, keen to know how it goes.

Unfortunately I am unable to install 4.0.4, I have an extra drive which I can swap out but my hardware is quite new and the 4.0.4 installer would not boot, I could only install 4.1.

Is the standalone you mentioned 4.0.4 or 4.1?

I’m currently running 4.1

Earlier this today, I successfully installed an iso of Debian in an empty standalone and had Tails running live in an empty standalone… so it’s not broken in 4.1.

Some possible approaches might include carefully making new standalones with the correct settings. Kernel = none… HVM virtualization… default VM pool… no template… enough allocated disk space… enough RAM. etc.

Then try to start them from dom0 with the command I posted above as well as entering the same info in the Qubes Manager settings (linking to the iso in another VM) and starting them like a normal VM.

Beyond that… I have no idea. Maybe try with a different iso?

1 Like

@necker thanks for your help, tried with two more ISO’s, Tails and Fedora 35, but same issue with both, so going to lay it to rest for now, when Rc3 comes out I will do a clean install and then try again.

Seems the issue is with my setup, unlikely it is something with my settings as I have changed almost nothing with Dom0, so I am thinking a hardware issue, time will tell.

One quick final question, you mentioned not installing AP Linux due to security concerns, just for my own understanding I thought each qube is a separate entity from the other qubes, if you install software that isn’t trusted into its own qube and then set the internet connection to ‘none’ would this still be a security concern?

There can be more risk if the VM has HVM virtualization. My understanding is that HVM increases the potential attack surface on your machine hardware. PVH is considered a more secure form of virtualization. That’s my understanding anyway. Perhaps someone else can clarify.

i think the opposite because hvm is hardware-assisted virtualization should be more secure than phv (paravirtualization) which is using software to provide virtualization interface

Perhaps you are contrasting HVM and PV? My understanding is that PVH more secure than both. Consider the following from the Qubes docs:

By default, every qube runs in PVH mode (which has security advantages over both PV and HVM), except for those with attached PCI devices, which run in HVM mode.

source: Standalones and HVMs | Qubes OS

1 Like

i didn’t found why, so let’s assuming that

Thanks guys, all good learning for me.

More details about the virtualization technologies: Are we safe just because we suck? - #11 by fsflover.

Hello everyone, this conversation died out sometime ago, but I have some new news to now add…
Just by chance I have discovered why my standalone qubes were shutting down before the installation process was complete, initially I had been leaving the memory settings as default: Initial 400 Mb, Max 4000 Mb, but when I change the Initial Memory setting to 4000 Mb the installation process carries on right through to the end, I have tried this with a few different OSes and it has worked for all.
Unfortunately I am now faced with a new problem, when the qube is restarted I get the following messages:

Booting from Hard Disk…
Boot failed: not a bootable disk

Booting from Floppy…
Boot failed: could not read the boot disk

No bootable device.

I have tried this with a few different OSes and the result is always the same, I can see in the Qube Manager that the software has been installed into the Qube by its Disk Usage, but for some reason it will just not boot, any ideas?

If it is not too late, on which of the available drives did you install
the OS?
How did you utilise the available disks?

Thanks for the reply, your question started me thinking and I realized it is possible I may have installed the OS into the wrong partition.

Solved: This time I changed the settings before loading in the OS and set the system storage to 32gb so there would be no mistaking it, still had to change the initial memory setting, but now I have Ubuntu booting as it should.

Many thanks :slight_smile: