AP Linux Standalone Qube

Hello everyone,
I am hoping there might be some other audiophiles here in the forum.
I have the idea of installing AP Linux into a standalone qube to play hires music, but am not having much luck creating a standalone qube.
The installation process for AP Linux is a bit more complex than some other linux installs so I switched to a couple of other easy installs to try to get them to work first.
Following the instructions in:

with all attempted installations the installer will start and then the qube will shutdown fairly shortly after beginning.
I am running Qubes 4.1 Rc2, and have tried everything I can think of, using both the GUI and command line procedures, changing memory and disk space qube settings but am stuck.
Any help, advise or general comments would be greatly appreciated, also keen to know if there are any other audiophiles here :slight_smile:

1 Like

any more info? what happened? any error?


btw, audiophile linux seem to have very slow development or the project is dead

Some more information would be helpful.
Does the qube launch the installer, get some way, and then shutdown, or
do you never see the installer?
Is there some consistency in the stage at which the qube shuts down?
Is there anything useful in the logs for the qube?
Have you made sure that you have kernel set to “none” in the settings
for the standalone?

I never presume to speak for the Qubes team.


When I comment in the Forum or in the mailing lists I speak for myself.

Thanks for the replies guys, I will do my best here, still fairly new to Linux and Qubes.

I was in touch with the developer of AP Linux recently and it hasn’t been abandoned, just as you say, very slow development.

I made sure the kernel was set to ‘none’, not sure where to access the logs for the qube or if I would recognize anything there that might be useful.

The installer will get just past the grub2 boot screen and then will shut down the qube, if I am starting the qube from the command line there is no error message.

If I am using the GUI to start, then I receive some error messages and the qube freezes:
“Booting from Hard Disk…”
“Boot failed: not a bootable disk”
Then it tries to boot from floppy and returns a no bootable device error.

Hope this helps.

have you tried to redownload the iso?

Yes, tried this, have also tried with different linux distro ISO’s, have a feeling it is something simple that I am doing wrong.

One more thing to note, when creating the qube there are three options to select from from the drop down list in Storage Pool: default (vm-pool), varlibqubes and linux-kernel.

If I select the first two options the qube will be created, however if I select ‘linux-kernel’ the qube is not created with the following error message: “Error: Got empty response from qubesd. See journalctl in dom0 for details.”

I see that the ‘not a bootable disk’ is simply the error returned when trying to start a qube with no boot iso loaded.

@unman could you please confirm which option I should be selecting from the Storage Pool list, is it ‘Linux-kernel’, this is not mentioned in the instructions, and if it is this option then this is probably my issue?

I will need to find the journalctl log in dom0 to progress but not sure how to do that.

lol, i didn’t expect that mistake possible :laughing:

What are your virtualization and kernel setting on the standalone? Qubes Manager → (highlight VM) → settings → advanced tab

[edit: oops… weird. First time I loaded this page, only the first three messages loaded. Not sure my question is as relevant now]

Any help is appreciated, this is quite a frustrating point to be stuck at.

On the advanced tab all Memroy/CPU, other and Window options are standard/normal. Virtualization is set to HVM and Kernel WAS set to (none).

I just noticed that the Kernel setting has gone back to (current), if I select (none) click ‘ok’ and reopen the settings it has gone back to (current), the same thing happens if I change it and click ‘apply’…

@ppc are you able to tell me which option I should be selecting from the ‘Storage Pool’ list, is it the ‘Linux-kernel’ option?

This is the only option that won’t work for me, the qube isn’t created.

[edit: see next message]

Wait… I know what you did. You didn’t create an “empty standalone”. You created one based on a template. You are trying to start a template-based standalone with no kernel. You need to create a new standalone based on no template (simplest way is with the Qubes Manager GUI). Then set the kernel to none and the virtualization to HVM and increase the private disk size to accommodate the new OS.

Then, with your iso in another VM, start up your HVM from dom0 with:

qvm-start <HVM_VM> --cdrom=<VM_with_iso>:/path/to/installer.iso
1 Like

It seems that (current) is (none), a little embarrassed there…

@necker I was certain that I created the qube as a standalone with no template, but just to be sure I deleted it and started fresh.

Unfortunately I am certain this time, no template was selected and the problem is still the same, and I had even less luck trying to use the default kernel instead of none.

When you create the qube are you using the ‘Linux-kernel’ option in ‘Storage Pool’?

No… “default (vm pool)”. I use the GUI from Qubes Manager and leave all of the advanced tab settings in the default position.

I actually like the idea of a standalone audio qube… I’ll see if I can get it set up. It might be an issue with Qubes 4.1 Keep in mind we are using an experimental OS. If you have an extra machine to install 4.0.4, you might want to give that a try. I’ll post here later to let you know the results of my install attempt.

[edit: I have the standalone and AP Linux iso ready to go but I’m unsure about security risks. I don’t like downloading 2 year old iso files from SourceForge with nothing but an MD5 checksum offered by the same download source… especially when installing on an HVM. I’m going to hold off on AP Linux for now and try with a different iso.]

Okay, keen to know how it goes.

Unfortunately I am unable to install 4.0.4, I have an extra drive which I can swap out but my hardware is quite new and the 4.0.4 installer would not boot, I could only install 4.1.

Is the standalone you mentioned 4.0.4 or 4.1?

I’m currently running 4.1

Earlier this today, I successfully installed an iso of Debian in an empty standalone and had Tails running live in an empty standalone… so it’s not broken in 4.1.

Some possible approaches might include carefully making new standalones with the correct settings. Kernel = none… HVM virtualization… default VM pool… no template… enough allocated disk space… enough RAM. etc.

Then try to start them from dom0 with the command I posted above as well as entering the same info in the Qubes Manager settings (linking to the iso in another VM) and starting them like a normal VM.

Beyond that… I have no idea. Maybe try with a different iso?

1 Like

@necker thanks for your help, tried with two more ISO’s, Tails and Fedora 35, but same issue with both, so going to lay it to rest for now, when Rc3 comes out I will do a clean install and then try again.

Seems the issue is with my setup, unlikely it is something with my settings as I have changed almost nothing with Dom0, so I am thinking a hardware issue, time will tell.

One quick final question, you mentioned not installing AP Linux due to security concerns, just for my own understanding I thought each qube is a separate entity from the other qubes, if you install software that isn’t trusted into its own qube and then set the internet connection to ‘none’ would this still be a security concern?

There can be more risk if the VM has HVM virtualization. My understanding is that HVM increases the potential attack surface on your machine hardware. PVH is considered a more secure form of virtualization. That’s my understanding anyway. Perhaps someone else can clarify.