Anybody able to use I2P?

Hi,

New to I2P. I just installed I2P in a Qubes Debian 10 template with sudo apt-get install i2p, configured a Firefox browser in a VM and started the router from terminal.

So here’s the thing:

  • I fail the bandwidth test.

  • I am firewalled, I get connections but cannot connect to any eepsite.

  • UPnP status says “UPnP has not found any UPnP-aware, compatible device on your LAN.” but I’ve checked my ASUS router and UPnP is on.

  • I’ve tried to forward the port I2P network config says it’s using in my router but no luck.

  • I’ve tried skipping the sys-firewall and going directly to sys-net but it’s no different.

I’ve looked at My first workable i2p in Qubes but it’s cryptic to me. How would I even make such a template ISO?

UPDATE: I’ve managed to access i2pforum.i2p and I don’t know how. It’s just extremely slow I suppose.

1 Like

Surprised no reply here… have seen mention of others using. I have run I2P for years just fine. From the above it just sounds like your port forwarding is not properly set up. See:

Near the bottom for instructions on forwarding a port to a qube from the outside world. Quite a PITA and a few scripts up on github with caveats that probably mean you should just start from the instructions above. Should really be integrated into the Qubes firewall, though there are different configs, inc VPNs, proxies that complicate the issue, so it has never been done. If you are using Debian sys- VMs you can ignore the nft setup.
You appear to be running the I2P setup wizard, not sure if that works (page 3 bandwidth test just sits there doing nothing for me). I use “use all methods to determine external IP address” in networking settings and it has always just worked for me, through many NATing firewalls and on VPNs.

1 Like

Yes I use I2P with split setup. My setup is as follows:

  1. Use VPN that supports external port forwarding
  2. Configure qubes-tunnel with port forwarding from “sys-vpn” to “sys-i2p”. Now I2P should have full connectivity.
  3. Configure I2P to accept client connections from qubes network interface rather than from localhost
  4. Use sys-i2p as network VM for i2p AppVM
  5. Use local IP of sys-i2p as HTTP proxy in Firefox in the i2p AppVM

Now the i2p AppVM can directly access the IP address of sys-i2p as a HTTP proxy because it is configured as the upstream network VM, so everything works nicely.

Everything in the AppVM that does not have a HTTP proxy configured will bypass I2P and will be routed via the VPN instead. Which is kinda meh in terms of anonymity but should be easy to suppress if necessary.

I just installed I2P in a Qubes Debian 10 template with sudo apt-get install i2p

IIRC the Debian version of I2P is very outdated, you should probably follow the guide here Debian/Ubuntu - I2P

1 Like