Any Way to make everything on screen bigger without resolution change?

Any Way to make everything on screen bigger without resolution change?

describe the problem further. What exactly is the problem you’re having? Are we talking about icons, fonts?

In Xfce, the default zoom is Alt+ScrollWheel.
You can do this from the keyboard using xdotool keydown Alt click 5 keyup Alt to zoom in, and xdotool keydown Alt click 4 keyup Alt to zoom out.
Put these commands in to simple scripts in dom0. Make it executable
with chmod +x, and test it works.
In Xfce, open “Keyboard” from the Menu - Select “Applications Shortcut”
and “Add” a link between the key combo and your new scripts.

In KDE it is, of course, much easier.
The defaults to zoom are Ctrl++ and Ctrl±
You can customise these in Settings, then Shortcuts.

1 Like

yes, the size of everything is really small. i have a really high resolution that won’t decrease and my screen isn’t that large

this really doesn’t help

everything gets bigger, but it’s a zoomed portion of the bigger area and so my cursor moving around changes what is on the display. it’s uncomortable and I’d rather squint

any other ways?

Perhaps you could be more explicit about what you want?
It sounds as if you want to decrease the resolution without changing the
resolution.

That’s what I want. The driver isn’t letting me change the resolution, so i want a differnet way

yes, i do want that, since i can’t lower the resolution. the driver won’t let me. any way to make a psuedo resolution so things look bigger? it’s so small

You can try going to the application menu under System Tools > Appearance and under the Fonts tab, change the Default Font size or the Custom DPI setting. This might accomplish some of the desired effect if you can’t change the resolution under the Display settings.

1 Like

When I zoomed in and zoomed out, the panel got all messed up. Some of the icons were in the wrong place. I tried to recreate the panel and the launcher isn’t showing up, I’m just seeing an A with a box around it. This is terrible

after zooing in and out, the panel is messed up. i deleted the panel and creeated a new one. launcher won’t show now, system monitor shows as (genmon)XXX and everything is pushed to the left. any way to fix this? it looks awful

@qubesn00b you want exactly what @tech3599 mentioned.

Custom DPI setting.

DPI stands for dots per inch (printing) and is often used interchangeably with PPI (pixels per inch). The default on most systems including Linux / Qubes OS is 96. So if your screen has a PPI ratio greater than 96, things start to look small or even tiny.

  1. Find out what your actual DPI setting should be. My laptop screen is 14 inches with 1920x1080 pixels (157 PPI) and my desk screen is 32 inches with 3840x2160 pixels (138 PPI). You can use DPI Calculator / PPI Calculator to calculate yours easily. No, this is not my domain but I would love to have it. :wink:

  2. Most software works best if the PPI is a multiple of 6. So in the above example the best PPI setting for my laptop screen is 156 PPI and for my desk screen it is 138 PPI.

  3. There really is no good way to switch DPI/PPI dynamically based on the screen currently in use. So I picked 138 PPI because more than 95% of the time I work on my desk and when using my laptop screen I don’t mind if things are a bit smaller (138 is still a lot better than 96).

  4. Setting this in dom0 couldn’t be easier. Just go to XFCE Settings | Appearance | Fonts and set the DPI to whatever value fits for your screen. After changing this in the settings dialog you should see an immediate effect on all dom0 windows like the settings dialog or the Qube Manager. Annoyingly the window borders don’t scale with the DPI setting in XFCE but there are two border styles that are configured to be larger for this very purpose: XFCE Settings | Window Manager | Style … choose Default-hdpi or Default-xhdpi whichever one works best for you. Personally I like the B5 style so much that I just stick with it even though it’s a bit smaller.

  5. Your qubes have no idea what DPI/PPI value you use in dom0. If your template do not use a xsettings daemon like gnome-settings-daemon, you are in luck. In that case you simply add the line “Xft.dpi: 138” or whatever your DPI setting is to the respective /etc/X11/Xresources (Fedora) or /etc/X11/Xresources/x11-common (Debian), shutdown the template and restart the qubes based on them and you are done.

  6. The standard Fedora template comes with the Gnome settings daemon installed. This means you have to install e.g. gnome-tweaks in the template and then run it in every single one of your qubes once. In it, under “Fonts” you can set a scaling factor (96 = 1 so in my case 138/96 = 1.44). It’s annoying, but on the upside you only have to do it once per qube.

1 Like

It’s too late now, but deleting the panel was the wrong thing to do.
If anyone comes across this in the future, just resetting zoom, logging
out and back in, will restore everything as normal.

Why is it bad? i recreated it but it looka different since some items are not aligned left and some aligned right.

you deleted it so you need to recreate but it not easy
at least you still can recreate it

i recreated it but want q on left and other stuff on right, don’t know how do that

i recreated it but want q on left and other stuff on right, don’t know how do that

First, this should probably be moved to a new topic.
Assuming you are using XFCE, open Panel in the Application Menu under System Tools. You can create multiple panels with the ‘+’ button at the top. Then you can set them to horizontal or vertical and move them by unchecking ‘Lock Panel’ and dragging the items at the ends of the panel, then checking ‘Lock Panel’ again. You can go to the ‘Items’ tab and use the ‘+’ and ‘-’ buttons to add or remove items on the selected panel and move them in the list. Most of it’s pretty straightforward and easy.

yes but the first panel had the q on left other stuff on right. second panel wont do it

Can you move the items in the ‘Items’ tab to change their order? Moving the application menu to the top of the list should move it to the left on a horizontal panel.
A screenshot would also be a great help.

I can move them, but the Q was flush left before and the other stuff was flush/aligned right, it doesnt do that no more