AndroidX86 issues

And not in the serving way :frowning:

I followed the community installation guide, and the point that it deviates is when I select Auto Install and it says that it has failed to mount the sda, then asks if I want to reformat, if you select yes then you are lead into an infinite loop of failed attempts. If you select no it reboots and then when you boot it back up it says no bootable drive, and then uses 100% of the CPU somehow while literally everything else is still running…

please help, you are my only hope

ps. there is literally no Root for qubes… was configured without it… are we fucked?

What error did you have? Or how exactly did it fail?

You can also try to use Waydroid instead of Android-x86:

1 Like

The root account in dom0 is disabled, but you can still access it in many ways, including sudo <your command executed with root privs>, sudo -s, sudo -i, and sudo su to name a few.

For root in templates the above also applies, but you may need to install qubes-core-agent-passwordless-root in the template.


It goes “Cannot mount /dev/sdaq
Do you want to format it?” I select yes and it shows the installation progress bar for two or three frames. Than it takes me right back to “Cannot mount /dev/sdaq
Do you want to format it?” again. If I do this 4-5 times than it says “Installation failed! Please check if you have enough free disk space to install Android-x86.” The options it gives me at this point are “Retry” and “Reboot” Both options result in the accursed loop continuing.

My purposes are to move a backup of an old android account into a VM. If Waydroid could work better for that than it could be the better option. I just got Androidx86 to work pretty easily on a previous flash. The only change has been two dom0 updates and configuring the new flash “without root”.

Not sure why Android-x86 won’t work for you.
I’ve tried to use android-x86_64-9.0-r2.iso image and followed this guide:

And it worked for me.
Check the VM settings, maybe you’ve missed something.

Waydroid should work as well.