Android-x86 and Bliss OS

Please help me with Android-x86 and Bliss OS on Qubes installation.

First step: create stand alone VM, and boot from ISO (android-x86 or Bliss OS).
Problem: failure message after booting - "There is no hard drive to edit partitions.”
Root cause: dom0 setup cause standalonevm to boot from /dev/xvd*, but ISO require /dev/sda.
Solution reference: follow the steps in the link below - problem is solved.

Second step: boot into the created standaloneVM and installed OS successfully.
Problem: after booting into the OS, it only give me symbol (LineageOS, Android, Bliss OS), and nothing else. I have tried all the available ISO from their download site.

Do we have to format the partition disk in standaloneVM with specific file type ?
And currently, any file type I choose to format, doesn’t appear after formatting.
As we see the file type format options, in the attached picture above,
there are no ext4, fat32, or ntfs options, as mentioned in some references.

Besides I found in the reference below, it uses vmware and IDE as its virtual disk type.

Anyone know the solution ?

any update to this? did you find a solution man?

Try the suggestion there to increase memory to the qube. I also exclude memory balancing.

Have you managed to run BlissOS 14.3 (Android 11) in a StandaloneVM ?
I tried BlissOS 11 (Android 9) and it works pretty well, however some apps crash because of a “” runtime c++ or java issue.
So I would like to install Bliss 14, but it is always stuck in a bootloop with a blinking _ , even with hardware acceleration disabled.

I have not tried Bliss OS 14 / Android 11.

Were you able to get it to work?

I haven’t tried it, but if you’re looking for a way to run android apps in a Qubes, this might interest you?

(I haven’t tried it)

Hi there, BlissOS came up with new releases lately. They do not work out of the box on qubesOS. Has anyone been able to run either BlissOS 14 or 15 successfully on qubesOS. If so would you mind sharing your approach?

Best regards

I have good news for you guys. Android86 works on Qubes 4.1.1
I installed it so many times, without any problem. Just be sure to choose GRUB during installation process and it boots without any problem.

The latest android x86 I could get installed was 9.0r2 I don’t think it gets updates anymore as it’s security patch level is from 2018. I assume Bliss os updates more offten and would love to get it installed. I am able to run bliss in live cd vesa mod when booting from the iso…

I found unman’s script and will be trying it out. Hope it works for bliss

I ran into some issues coping the file stubdom-linux-rootfs It doesn’t exist on qubes 4.1 so this script might be meant for 4.0 Now I am reluctant to try this without backing up my system overnight. I might try it tomorrow. Anyone else try this script on 4.1?

I guess there’s no need to patch anymore on 4.1 as I have successfully installed the Bliss OS 14 now. But I encountered messy lines display instead of Android logo. Here is my step to reproduce: Messy lines are displayed after Bliss OS 14 was installed - User Support / General - Qubes OS Forum (