After shutting down sys-net, I can no longer connect to the internet

After attempting to assign the DNS of sys-net to the router’s address through GUI, I encountered unresponsiveness upon right-clicking, and a cross mark appeared on the computer icon. Although I could regain control after a reboot, I was only able to shut down and not restart. Upon shutting down, all open cubes were closed, resulting in a frozen-like state. After some time, sys-net recovered, but since then, it has been unable to connect to the internet.

DHCP allocation seems to be absent in PFsense as well. While sys-net can be rebooted, repeated attempts at restarting, manually setting IP addresses, and even QubeOS restarts did not resolve the issue. After each restart, a message consistently appears indicating that the device has been removed.

I’ve also tried restarting QubeOS itself, where only once a green spinning icon appeared, but subsequent attempts left the computer icon unchanged with a cross mark. I hope the LAN itself is not damaged. Is there any way to revert to the previous state through a QubeOS configuration adjustment.

You can create a new qube sys-net2 with the same settings and attached PCI devices as sys-net and test it.

1 Like

Thanks, I made a clone of sys-net (sys-net2) and tried to start it after shutting down sys-net. But I still get the same error and the icon is still a cross on the computer. Only the ens6 (with MAC address) is shown on the device, and the sys-net one also shows vif.

When I enter lspci in dom0, the ethernet controller is shown, so it is not broken? Maybe. If I can re-register this to sys-net, will the net be restored?

Don’t clone the non-working sys-net. Create a new one with “Create Qubes VM” tool and then set the new qube settings to be the same as old sys-net.


I created a Qube from the Create Qubes VM and ticked Provides network access to other qubes, How should I allocate Ethernet?

I was able to find a way to add it! But it seems to come up with can’t attach pci device to VM in pvh mode.

→ HVM mode, and I was able to add ethernet, so I tried booting without changing. But it seems to come up with can’t attach pci device to VM in pvh mode…

In sys-net2 Settings → Advanced tab:

  • uncheck Include in memory balancing
  • set Virtualization mode to HVM

In sys-net2 Settings → Devices tab:

  • add your network controllers (the same ones as in sys-net)
1 Like

Yes, I tried to do exactly that. But when I start, I still get an error that the device has been deleted (as shown in the captured image) and it does not seem to be connected.

Can you check the logs in sys-net/sys-net2 terminal for errors?
You can run sudo journalctl to see the logs.

1 Like

Thanks for your continued support. I was having dinner with my family, sorry, I made some sys-net and the HVM/Ethernet/memory/ is the same. I don’t know if this is correct, but when I try to start the terminal, I get the error in the image and cannot open it.

No, I made a mistake. It was a conflict. sys-net5 was killed and the terminal was successfully started.

エラーらしいものはいくつかあるようです。HVMOP / e820: remove など。他のsys-netも同様です。

Those are not relevant messages. Try to look for messages containing words “error” or “fail”.
Also check the log from the end to see the messages from the latest boot.

1 Like

You can use this command to only see the messages for current boot:
sudo journalctl -b

1 Like

I rebooted(sys-net) again, put the error on the top right screen and then did sudo journalctll -b.

[Firmware Bug] TSC doesn’t count with p0 frequency!
The only error I can find is.

Greyed out is
HVMOP_pagetable_dying not supported
e820; update [mem 0x00000000-0x00000fff] usable ===> reserved
e820; remove [mem 0x00000000-0x 00000fff] usable

Perhaps errors are shown in red, but I don’t see any Error messages; do I also need to do journalctl -b with dom0 or etc.

Now reboot the system and try the same thing.

The messages:
Device /tmp/sanity-squashfs-* (deleted) has been removed
Seems to be related to snapd and shouldn’t be related to your problem.

1 Like

Maybe you’ve installed something in sys-net template that is causing this problem?
Try to use a different template for sys-net.

1 Like

The sys-net is configured with dafault-dvm and debian11 is the default template. I used to have someone in the know tell me how to set up Telegram to make security robust, but I had to create a Qube for each application as shown in the image.

Another template, fedora-38-xfce, does not give any sanity errors and the connection remains unconnected, debian-12-xfce is the same, also no sanity errors.

Do you see your network controller interface in sys-net when you run this command in sys-net terminal?
ip a
If it’s present then is it configured with correct network settings? And what is its status, is it UP/DOWN/UNKNOWN?

1 Like

Hmmm, I may not be able to make a decision, but since it is NO-CARIER, BROADCAST, MULTICAST and UP, it may assume it is DOWN.

It seems that your network controller is detected (ens6/enp0s6 interface) but is not configured.
Can you check the log messages for errors related to ens6/enp0s6 inteface?

1 Like