Aborts installation at 'Installing Network Drivers' and then enters into a black screen with a single curser in the top left corner

Hi, I am currently using a Dell Inspiron15R with 8 GB RAM and an i7 processor. I successfully flashed the Qubes ISO on a USB stick and then tried to install it onto an external hard drive in both UEFI and Legacy mode.

All the steps run smoothly after the first reboot into the drive, which requires me to configure the OS (the one where I can chose to update over the tor network), however after a long installation time the dialog box finally displays Installing Network Drivers before it unexpectedly crashes and then displays a black screen with just a single cursor at the top left corner.

I left my laptop in that state overnight hoping it would reboot but to no avail. No commands work at that point so I had to force my laptop to shut down by long pressing the power button, following which it then booted into the external drive again but ended up giving me the ‘dracut initqueue’ timeout error, because I am guessing that somehow the initial install got corrupted.

Could someone please help me with this?

It may be this: Installation Troubleshooting | Installation freezes at “Setting up Networking”.

Hey @deeplow

I tried to update my network drivers, but they were already up to date. Then I tried by disabling my NIC card in BIOS before the install but it still gives me the same error of a black screen with just a small cursor on the top left corner towards the end of the install.

This post here seems to describe the error that I am having: Install hangs at "Setting up networking" · Issue #4494 · QubesOS/qubes-issues · GitHub

However, the same issue occurred at the same step with Qubes 4.1 so it really has something to do with setting up sys-net/sys-firewall.

I recently got hacked and they took 40% of my net worth! I believe that I am currently being targeted here because I am in possession of proprietary IP. Solving this issue is really important for me. Thank you for the help.

A while ago I got the same exact symptoms but the issue was I was trying to install it in an external SSD and forgot to disable sys-usb on the setup step. Are trying to do something similar?

1 Like

Yup, that is exactly what I was trying to do and then it finally worked after unchecking sys-usb!

However, I am still unclear about how to setup sys-usb post install and about how to get it to connect to a mobile hotspot, which is currently not showing up in my WiFi networks.

1 Like

How many USB controllers do you have? If you have only one it probably won’t be possible since Qubes itself is being loaded from that USB controller. If you have more than one I think this is possible. Take a look at USB qubes | Qubes OS and pay special attention if you’re using a USB keyboard and mouse.

Also, I’ve propposed a change to the documentation on “installation troubleshooting” to mention this case as well since two users have now reported it (you and myself):

1 Like

Well I have 4 USB ports so I will move ahead with following the steps in the documentation.

I also stumbled upon this post of another user who had a similar issue: Qube OS Installation Black Screen

With regards to connecting to a mobile WiFi hotsopt, what do you think is preventing qubes from discovering it?

This may be another issue. I’d suggest you open another thread for it.

Hi - not sure if I should post here or start a new thread - I’ll try here first:
I’m experiencing the same thing - where the installation stalls at the network setup. I’m using a Dell Lattitude E6420.
However, I’m not installing on an external usb drive. I’m doing a regular install on my internal ssd drive.
From researching online, I assumed it was a driver issue with my Qulacom wirless card. And, I’m hesitant to get a different card because I’m not confident that there won’t be compatibility issues with that one as well.
I do see that the E6420 should work based on the hardware compatibility lists. And, it will install for me if I uncheck everything and go for a custom install. But:

  1. I’m not at the point where I can do a custom install yet.
  2. Just because the base setup can install, that doesn’t mean it wont fail again when I try to install the network manually.
    So, my question is – is there a workaround for my installation issue? Is that USB workaround applicable to my situation?

You just need to disabled sys-usb during the configuration step of the install. As far as I can tell turning the network card on or off had no major effect for me.

There is a huge difference between the number of ports and the number of
You can have a large number of ports off one controller.
You can have one controller per port.
The only way to confirm is to run lspci |grep -i USB - this will show
you the controllers, slot, and type.

You may be lucky.


Hi AlanT,
I’ll give that a shot.
But after that - did you ever figure out how to setup sys-usb post install?

Disabling sys-usb during config did not work for me. It still hung up at network config. I think it’s compatibility with my network card. I’ll start another thread so as not to hijack your thread.


Hey @skess

I believe that this article goes over the steps: USB qubes | Qubes OS

I am sorry to hear that disabling sys-usb didn’t work. However, before I tried the second install with sys-usb disabled I had tried an install with my network card disabled and all of the other options disabled as well just so that I could enter into the login screen. Then in the middle of the install process when the dialogue box was up, I clicked on the configuration menu again and reselected all of the options above sys-usb.

But what I am using now is a fresh install that I performed with the network card and sys-usb disabled. Hope this helps!