4.2RC2 Windows HVM - cant attach any SSD storage via usb

This is a quite odd problem.

I have an old rotating disk attached via usb to a windows standalone HVM.
That works. It appears in the file browser in windows.
But when I attempt to attach any SSD type storage ( Both M2 and 2.5" ) they wont show up. They dont register at all. The disk management in Windows dont see it either.

What am I missing here ? I tried following a guide Windows USB integration with R4.1

But it doesnt seem to help as nothing shows up. Its not a wrong format of the drive because its NTFS and windows can see it. I can attach the storage to a debian VM and it shows up fine. Its just in windows it wont do this. Do anyone know how to allow me this ?

Are you attaching in as block device or as USB device?
Attaching as block device don’t work without Qubes Windows Tools installed.

I tried attaching it as a block as that works with a rotating disk.
I just for fun tried taking an old hdd and plugging it in.
It works. Its only when i try an SSD that it wont show up.

Do you know where i can download the qubes tools to install in the windows vm ?

Is it listed under Data (Block) Devices or under USB Devices?

Yeah it does show up. I can attach it to any other VM just fine. Just not the windows 10 one.

You didn’t answer, is it listed under Data (Block) Devices or under USB Devices?

Ah sorry.
It shows up under both. With the partition under block device but Im using the USB at the bottom to connect it.
Like I said, it works perfectly fine with a rotating. Just not an SSD which is odd. Im using the same usb cable. And the ssd mounts fine in a linux vm. So everything works. Just simply doesnt show up in windows.

So you connect your SSD with the same USB adapter as your HDD?
Is it listed in Qubes Devices widget both under Data (Block) Devices and under USB Devices as well?

Hm thats odd. I just tried again and now it works. Seems its the controller for my other ssd.

It looks like its only certain controllers that dont want to attach to windows.

Maybe it needs some drivers to work.

Yeah. Thats what Im beginning to think as well. Problem is. Where would I need to install them ?
I know windows itself can read these just fine as a plain windows installation will make it show up. I know qubes sys-usb can see it as they show up in the linux vms as well. So somewhere between Qubes os and Windows does it stop working.

Open the Windows Device Manager and attach your SSD as USB device using Qubes Devices widget then see if the new device will show up in Windows Device Manager. Then check this device drivers or other info.

Thanks. Ill try that and get back to this.

I narrowed it down to it most likely being the USB 3.0 not working in the Windows 10 HVM

Its some chinese 2.5" drive that i got. It works in a native Windows 10. It works in linux. It does not work in WIndows 10 in a Qubes VM.
Is it some USB3.0 Issue ? Is there some drivers that I need or how would I go about attaching it ?
I can see a unknown USB 3.0 hub in the device manager in windows. But I have no idea which driver to install as microsoft doesnt exactly have windows 10 drivers for a qubes os vm.

Get its VID:PID in device manager and try to find the driver for this VID:PID somewhere using search engine.

Thanks. Ill look for that. Ive found a workaround by using a different type of adapter.