Qvm-create-windows-qube Qubes Windows Tools install hangs on the "Completing setup of Qubes Windows Tools" step

I’m trying to create a Windows VM with the qvm-create-windows-qube tool and the latest Windows 10 x64 ISO from the Microsoft website. There’s an older discussion that seems to have solved the problem but it doesn’t work for me (I already have qubes-windows-tools-4.1.70-1.fc32.noarch installed). The symptoms are identical. Has anyone faced the issue or knows how it could be fixed?

I was using this script a couple of years ago, thanks to @elliotkillick for it.

But the last time I manually followed two official guides for R4.1 how to install Windows and QWT, and it worked way better than several years ago when qvm-create-windows-qube worked better for me.

I still have a couple of minor issues with Windows qubes like:

  • Alt+Tab is sticking Alt and Win keys (very annoying),
  • no arbitrary resolution available.

But in general the installation of Windows and QWT is now way more straighforward and rewarding even without this qvm-create-windows-qube. You may give this way a try if stuck with the script.

The windows tool is not available because of QSB-091.

It was replaced by a text file instead:

It could be why you’re stuck there. I don’t know how this script work but you have to skip this part of the installation for it to continue.


i do not know what to do if i want to integrate any connected USB devices to my windows 10 vm on qubes if i cannot install the qvm-windows-tools, are there any workarounds or any alternatives we could set up to get our windows vm’s to work better with qubes os?

If you are willing to accept the risks described in QSB-091, you may still install the previous version 4.1.68-1 of QWT, which is still available from https://yum.qubes-os.org/r4.1/current/dom0/fc32/rpm/qubes-windows-tools-4.1.68-1.noarch.rpm.

After downloading the rpm file and installing it in dom0 via sudo dnf install, proceed as described in Installing and Using Qubes Windows Tools in Qubes R4.1.


I don’t think you need QWT to attach usb devices to Windows HVM. This idea is from reading Windows USB support through Qemu · Issue #5802 · QubesOS/qubes-issues · GitHub and glancing at easydozen’s works. Feel free to correct me.

thanks for your reply, this did really work! but now I can’t seem to ever get windows tools to work as it once had done after complicating my first windows 10 installation resulting to an uninstallation. now the windows-tools package just isn’t working for me ever again, i’m also finding it hard to remove/uninstall the package, which may fix things. but the package & files are installed within dom0. Which wouldn’t happen if it it was any other VM

this right here is a bit too risky & complicated for me, it’s also an older work-around, thanks for the suggestion

1 Like

In dom0 you should just have the iso file, which should show up as a CD-ROM drive D: in the Windows VM if you start it with --install windows-tools.

There you can start the Windows installer, and also remove QWT via the Windows control panel.

1 Like

yeah starting the VM with the qubes tools ISO file is working as it should for me, but now whenever I install the qubes tools again on a brand new windows 10 vm, it just never works again. i can’t seem to remove any files (maybe there’s nothing to remove?) that may have been left at dom0 from between new windows standalones which is causing the conflict but I can’t seem to remove anything that will allow QWT to work again.

thanks for your input, it’s been great!

The old version of the package can be installed by:
sudo qubes-dom0-update qubes-windows-tools-4.1.68-1

1 Like

what are the risks if I want to use windows for adobe products(hacked) only? I don’t need i-net connection for these, but I absolutely must have to be able to transfer files quickly between the vms… am I still going to be under the risk if I choose to install the prev version?

Any risks are probably restricted to the Windows qube you are using. You can minimize these risks if you use a dedicated AppVM for these tasks and move any files downloaded to a minimally configured Linux qube - e.g. just containing a PDF viewer and no other software.