4.1 upgrade - sys-net to F35

I installed 4.1 onto 2016 Alienware 15 inch. updated it. I updated to Fedora 35. I set sys-net on install to temporary. Something like that. To reset each time. Not sure what all the implications are.

I tried to set ‘sys-net’ ‘sys-usb’ ‘sys-firewall’ to Fedora 35, Internet connection did not work. I tried to clone ‘sys-net’ Qube and choose Fedora 35. No internet connection. Fedora 34 is chosen, has internet connection.

So I went on to create more trouble for myself. I Cloned the Fedora 35 Qube Template. (Fedora 35-clone-1) then ignoring the warning. turned on the internet connection (sys-net pointing at Fedora 34 still works) (BTW, the connection is at a library, has no password or garden wall. The folks who installed internet connections at my public library has a nice room full of equipment and an incredible good internet strong fast internet connection which never hiccups on accessing Linux sites, privacy sites. None of the restraints that I see at McDonalds Internet connection, like some pages from this community forum will not load. They load just fine if I switch to a VPN, so it is not a browser limitation.)

Back to me making more trouble for myself. With the internet connection enabled on the Qube, I installed Firefox, qvm-open-in-DVM, Software, Text Editor. I let Software populate itself. and it did not offer an install for my VPN. So I updated Firefox and downloaded the App provided by the VPN. Which then magically appeared in Software as being available to install. Which it happily did, and worked. I created this template to use for a Disposable - Fedora 35 -dvm, clone Qube. Hmm, I do not see that at the moment. I think I have to clone the current Fedora 35-dvm, and point it back at Template Fedora 35 clone-1, which has the VPN App. I have never taken this install of Qubes 4.1 to McDs. Just the public library, which I hope has not changed any policy on spyware, malware, and so on.

I now suspect, this would have gone easier if I had installed Qubes 4.0, and used the installer process shown on the Qubes OS site on upgraded to 4.1.

Someplace in all this I also turned on Whonix Tor Browser, and updated it. I once had an experience where updates did not work before I turned on Tor Browser, guessing since I selected update through Tor, it did not then, months ago, did not update.

So once again. I can either find the magic of updating sys-??? to Fedora 35, or I should just install Qubes 4.0, and run the neetzy keen installer provided. Then mess up an F35 Template to install VPN, other stuff.

How did you update to Fedora 35? Did you install new fedora-35 template in dom0? Or just updated old fedora-34 template to Fedora 35?

from the post from the Gardner. Thank you Gardner

sudo qubes-dom0-update qubes-template-fedora-35

Set sys-net template to fedora-34 template then try to ping
Then change template to fedora-35 and try to ping as well.
Will ping work only for fedora-34 template?

Sorry I have not replied. As you can guess from my other posts, I use other places than home for downloading things. I can get online and do forum a bit, email, and such on a Hotspot connection with my cell phone.

I had to see doctors, and all the spent time with that.