Yet another debian-10-minimal vpn thread (notifications)

journalctl: [session uid=0 pid=882] Activating via systemd: service name='org.freedesktop.Notifications' unit='dunst.service' requested by ':1.1' (uid=0 pid=880 comm='notify-send test' ")
(The requested by changes, eg. :1.3/:1.7 etc)

This (requested by) is the culprit that causes the headaches with notification daemons. Has anyone found an elegant solution to this? I’ve tried specifying Environment=DISPLAY=:0 in dunst.service but that has no effect, I’ve put it in front of ExecStart, no effect. I’ve tried systemctl --user import-environment DISPLAY, nothing.

I have been reading countless threads about this issue and the fact that I haven’t found a solution in 4 hours other than “minimal templates are for aDvAnCeD usErs” is not good enough for me and I’d like to solve this once and for all.

OS Version: Qubes 4.0.4, TemplateVM: debian-10-minimal.

I’d like to rectify/clarify the information I put into the thread description. Requested by doesn’t actually cause the problem. The issue comes from the rc.local service being run before Xorg. From journalctl I can see that the pid of the notify-send command is around 750 while Xorg is at 810.

I tried creating another service to run after qubes-gui-agent but it is still too early. You’re going to have to accept not seeing the early VPN connection notifications or sleep until Xorg has finished setting up.