Xrandr HDMI Disconnected


I’m trying to enable HDMI on my ACER NITRO V15 laptop. When I do xrandr, one line shows :

HDMI - 1 Disconnected (normal left inverted right x axis y axis)

How can I ‘connect’ it ?

For info, I’ve been able to have dual screen using a USB-C hub with a VGA plus on the hub), but not directly using the integrated HDMI port.

I’ve seen this tuto to make NVIDA the primary display, but I believe Qubes (and/or linux without the proprietary drivers) has some issues using it, so I wouldn’t want to mess things up bu following this guide.

When I checked the glxinfo (per the tuto above), it shows that the vendor for my config is Intel, and the renderer is Mesa Intel(R) Graphics (RPL-P), so I’m guessing it’s using the integrated Intel Graphics and not Nvidia to diplay everything (which makes it work with Qubes).

Do I need to make NVIDIA the default Graphic in order to enable HDMI ?
Wouldn’t it screw the whole setup ?
Is it possible to enable HDMI keeping the Intel Graphic as the default renderer ?

Any insight would be appreciated (before I screw everything :))

I guess HDMI is connected directly to NVIDIA GPU and there is no way to use HDMI without using NVIDIA GPU.

Well, that is fine with me, but wouldn’t make NVIDIA the primary GPU dsplay screw the whole display thing with Qubes ?

Anything could screw things up, but it should work properly with correct drivers in general.

With Linux Nouveau or the NVIDIA proprietary ones ?

It depends on your GPU. Proprietary drivers have more chance to work correctly.

Wouldn’t it be possible to use the Intel Graphics for everything and use/connect/pass the NVIDIA Graphics to a specific Qube ? At least I wouldn’t risk to not have any display at all, and could have this one Qube using extended NVIDIA capabilities ?

Maybe your laptop is designed differently and you can connect the iGPU output to HDMI directly, but if HDMI is wired directly to dGPU without some switch then you can’t use HDMI with iGPU in dom0 and passthrough your dGPU to some other qube.

You need to have MUXed laptop with a switch:
[GUIDE] Optimus laptop dGPU passthrough · GitHub

You can check the BIOS, maybe there’s an option to switch the the GPU connected to HDMI.
In Dell there is such an option:

As far as I know, Dell precision 7000 line-up can enable DisplayPortDirectOutput mode in BIOS, which would route GPU signal directly to video output port, while keeping iGPU rendering the built-in display.

1 Like

Oh, waho… Very interessting, but most likely way above my technical knowledge…

Especially when I read : “Sorry but currently I don’t know how to check if your dGPU load its firmware through acpi call.” :slight_smile:

I checked the BIOS, but couldn’t locate such option… I guess I can ask the manufacturer and see…

I read many have had issues with the Nouveau Driver, and at the same time I really would prefer NOT to install proprietary drivers with this laptop and Qubes…

Thanks for the MUXed hint, that clarifies a lot (I mean I understand the logic, doesn’t mean I feel confortable digging into all this - at least for now).

try with nouveau driver, if it works it’s great. If it doesn’t, give the proprietary driver a try to check if your issue is related to nouveau.

Checking dom0 :
dnf search nouveau

Shows I have nouveau (at least it’s present) :

I found this : Optimus · freedesktop.org
And when I check xrandr --listprovider, It shows only 1 provider…

Nouveau seems to be installed, the NVIDIA card appears with lspci, yet somehow seems “inactive” ?

I can’t make backup for now, but I guess I’ll investigate this “switcheroo-controller” later on…

Unless there is a trick I’m missing and I should already be able to see/use the Nvidia card with nouveau ?

Check in dom0 terminal
sudo dmesg
sudo journalctl -b -k
to see if there are any errors related to nouveau or your NVIDIA card.

nouveau is automatically loaded out of the box, if you ever install the proprietary driver, you will have to block nouveau from loading.

your NVIDIA card is a discrete GPU, it’s always trickier to make it work…


Yep, one error with nouveau (in red) : nouveau 0000:01:00.0 unknown chipset (197000a1)

My GPU : GeForce RTX 4050 Max-Q.

I guess it means I should probably go full on with the official NVIDIA drivers… Not fun, but… I can live with that (and next time look for some AMD cards :))

I’m adding the other few errors I’ve seen since I’m guessing they may be related :

This one is in yellow :

pciback 0000:00:14.3 xen-pciback: Driver tried to write to a read only configuration space field offset 0x48, size 2. This may be harmless but if you have problems with our device :
1) see permissive attribute in sysfs
2) report problems to the xen-devel mailing list along with details of your device from lspci

Another one : I’m sorry, I don’t know how to copy text from terminal to elsewhere

Since I’ve seen the ACPI thing could be involved in the way Graphic Card are dealt with…

Antoher one, in yellow : the reason I’m adding this one is because I’m reading somwhere in the line “snd_soc_hdac_hdmi”…

I guess I’ll backup everything and see where the NVIDIA proprietery drivers take me…

Thanks a lot for taking the time exploring this with me.

I think it’s related to your network controller attached to sys-net or to USB controller attached to sys-usb.

The other two seems to be unrelated to your GPU as well.

And I guess I can’t keep the setup as is, and just try to have the VM “grab” the NVIDIA card by having the NVIDIA dirvers in the VM and not in Dom0 right ?

That would make sense, especially from a security prospective, but just checking…

Same thing with this SR-IOV thing, right ? Ie even if it seems possible with Xen and Nvidia, first I’m not sure (at all) that my motherboard can do this, and I would still need to have the NVIDIA proper drivers installed in Dom0, right ?

Anyhow… Way above my technical abilities.

Going to see that Nvidia Proprietary Installation Guide :slight_smile:

And this one too, a gaming HVM, seems really cool (but not sure yet it’ll allow me to NOT install NVIDIA drivers in Dom0) :slight_smile: