XFCE tap-to-click touchpad

Hello! I have long used KDE with Qubes 4.1, but after upgrading to Qubes 4.2, I decided to try XFCE once more as it seems to just be a tad more responsive (faster) on my machine than KDE is with Qubes. But, as I have played with it, I am now remembering the reasons I stopped using it the first place: KDE seem to automatically (out of the box) behave in a more modern (intuitive for less experienced users) way and appears to have far more customization that is easily accessible via menus. And one of those things is “tap-to-click” for touchpads. I almost need this function when I don’t have my external mouse with me. Does anyone know how it can be set up?

To be clear, I did dig around the forum here as well as on other sites just to see how to configure XFCE in general, and I largely found this response: Edit the file /usr/share/X11/xorg.conf.d/50-synaptics.conf and add the following lines

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "TapButton1" "1"
        Option "VertEdgeScroll" "1"

This is found from this page, by the way. Firstly, the conf file they want me to edit doesn’t exist in the folder. I assume that’s because it is not using the synaptics driver? On another linux machine, I would not hesitate much to try this, but I am concerned about how that might interact with dom0, mostly just because I don’t fully understand how it would interact with Xen (if at all) or future upgrades of dom0. It sounds like it forces a switch to the synaptics driver and I don’t want to break anything that I might not yet understand. Any XFCE users with experience on this topic?


I enabled tap to click by going to Qubes menu > system tools > mouse and touchpad > devices tab. Looked for touchpad on the list of devices, switched to the touchpad tab, and ticked “tap touchpad to click”.

No need for editting config files in my case

1 Like

I spent literally minutes in that menu and I could have sworn I didn’t see that touchpad tab available. But now after checking again after reading your post, I see it there and it is working…
Thank you!!!

1 Like