XFCE launcher qvm-run and command line flags

How do I add command line flags to a XFCE launcher in Dom0?
I installed Ungoogled Chromium and this is the default command when I create a launcher:
qvm-run -q -a --service -- untrusted qubes.StartApp+ungoogled-chromium

If I add a command line flag at the end, chromium does not start anymore:
qvm-run -q -a --service -- untrusted qubes.StartApp+ungoogled-chromium --js-flags=--jitless

I know that sometimes you need to use quotation marks, but I’ve tried these and it also doesn’t work:
qvm-run -q -a --service -- untrusted qubes.StartApp+"ungoogled-chromium --js-flags=--jitless"

qvm-run -q -a --service -- untrusted "qubes.StartApp+ungoogled-chromium --js-flags=--jitless"

Does it start from untrusted qube’s terminal with command line flags?

Yes, from the terminal in untrusted appvm it works fine.

Is it possible to create a shortcut in the menu which would include flags (for example ungoogled-chromium-flagged) and then to call it via qvm-run -q -a --service -- untrusted qubes.StartApp+ungoogled-chromium-flagged?

i didn’t try this because I still don’t have UC installed.

1 Like


Note that you can create a shortcut that points to a .desktop file in your app qube

1 Like

Yes, adding the flag to the .desktop file in the TemplateVM fixed it! Thanks!

1 Like

You are welcome. You may want to flag the post as solution, so it could help others too.