Wrong but still successful manual upgrade to 4.1

Hello people,

just to make sure I don’t miss something.
I ran an upgrade to Qubes 4.1 today, but the qubes-dist-upgrade --all crashed at Stage 1. (Some VMs didn’t want to update and the process hang for 20’ - then I closed the console and started it again, this time manually.) I had to start from Stage 2, but wrongly I started the Stage 3, which ran successfully. Then I tried to run Stage 2 → without success. I decided that I will be able to upgrade the VMs at a later point so I continued. At the end I ran Qubes Update for all the systems.
Now everything seems to be fine (I had that issue: Error: Failed to import module localemod - #6 by ivan-jli , it’s fixed). Do you find some other possible hidden issue there?



What is your Qube Manager saying in “About”->“Qubes OS”->“Version Information”?

Thank you for replying fsflover. It says “4.1.1 (R4.1)”.

You should also go to “Version Information” there and tell us which packages are listed in it.

1 Like

How has this worked out for you?

You might be interested in this post. Qubes-dist-upgrade (4.0 to 4.1) Break down / Manual upgrade option. In particular what steps may have been missed in STAGE 1 & 2.


May I have a list with the “right” versions of the packages? Is there an easy way to get such, or I have to go trough all the packages manually and see which version is the right one?
If I run on my actual state of qubes “qubes-dist-upgrade -l”, it tries to upgrade my windows TemplateVM and it fails:

2022-07-30 17:10:04.659 qrexec-client[10995]:qrexec-client.c:184:connect_unix_socket: connect: No such file or directory

so the process is aborted and the other VMs are left untouched.



Here is my list of (I believe) fully updated packages listed in “About”->“Qubes OS”->“Version Information”:

xen_version            : 4.14.5
Linux 5.15.52-1.fc32.qubes.x86_64
Installed Packages:  
grub2-qubes-theme.x86_64                          	5.14.4-2.fc32 
kernel-qubes-vm.x86_64                            	1000:5.10.109-1.fc32.qubes 
kernel-qubes-vm.x86_64                            	1000:5.10.112-1.fc32.qubes 
kernel-qubes-vm.x86_64                            	1000:5.15.52-1.fc32.qubes 
python3-qubesadmin.noarch                         	4.1.23-1.fc32 
python3-qubesdb.x86_64                            	4.1.13-1.fc32 
python3-qubesimgconverter.x86_64                  	4.1.16-1.fc32 
qubes-anaconda-addon.noarch                       	4.1.8-1.fc32 
qubes-artwork.noarch                              	4.1.12-1.fc32 
qubes-artwork-anaconda.noarch                     	4.1.12-1.fc32 
qubes-artwork-plymouth.noarch                     	4.1.12-1.fc32 
qubes-audio-daemon.x86_64                         	4.1.21-1.fc32 
qubes-audio-dom0.x86_64                           	4.1.21-1.fc32 
qubes-core-admin-addon-whonix.noarch              	4.1.1-1.fc32 
qubes-core-admin-client.noarch                    	4.1.23-1.fc32 
qubes-core-dom0.noarch                            	4.1.27-1.fc32 
qubes-core-dom0-linux.x86_64                      	4.1.23-1.fc32 
qubes-core-dom0-linux-kernel-install.x86_64       	4.1.23-1.fc32 
qubes-core-qrexec.x86_64                          	4.1.18-1.fc32 
qubes-core-qrexec-dom0.x86_64                     	4.1.18-1.fc32 
qubes-core-qrexec-libs.x86_64                     	4.1.18-1.fc32 
qubes-db.x86_64                                   	4.1.13-1.fc32 
qubes-db-dom0.x86_64                              	4.1.13-1.fc32 
qubes-db-libs.x86_64                              	4.1.13-1.fc32 
qubes-desktop-linux-common.noarch                 	4.1.12-1.fc32 
qubes-desktop-linux-manager.noarch                	4.1.14-1.fc32 
qubes-desktop-linux-menu.noarch                   	0.2.1-1.3.fc32 
qubes-dom0-meta-packages.noarch                   	4.1.21-1.fc32 
qubes-gpg-split-dom0.x86_64                       	2.0.60-1.fc32 
qubes-gui-daemon.x86_64                           	4.1.21-1.fc32 
qubes-gui-dom0.x86_64                             	4.1.21-1.fc32 
qubes-img-converter-dom0.x86_64                   	1.2.11-1.fc32 
qubes-input-proxy.x86_64                          	1.0.26-1.fc32 
qubes-input-proxy-receiver.x86_64                 	1.0.26-1.fc32 
qubes-input-proxy-sender.x86_64                   	1.0.26-1.fc32 
qubes-libvchan-xen.x86_64                         	4.1.7-1.fc32 
qubes-manager.noarch                              	4.1.23-1.fc32 
qubes-menus.noarch                                	4.1.12-1.fc32 
qubes-mgmt-salt.noarch                            	4.1.14-1.fc32 
qubes-mgmt-salt-admin-tools.noarch                	4.1.14-1.fc32 
qubes-mgmt-salt-base.noarch                       	4.1.4-1.fc32 
qubes-mgmt-salt-base-config.noarch                	4.1.1-1.fc32 
qubes-mgmt-salt-base-topd.noarch                  	4.1.3-1.fc32 
qubes-mgmt-salt-config.noarch                     	4.1.14-1.fc32 
qubes-mgmt-salt-dom0.noarch                       	4.1.14-1.fc32 
qubes-mgmt-salt-dom0-qvm.noarch                   	4.1.4-1.fc32 
qubes-mgmt-salt-dom0-update.noarch                	4.1.9-1.fc32 
qubes-mgmt-salt-dom0-virtual-machines.noarch      	4.1.17-1.fc32 
qubes-pdf-converter-dom0.x86_64                   	2.1.12-1.fc32 
qubes-release.noarch                              	4.1-2.fc32 
qubes-release-notes.noarch                        	4.1-2.fc32 
qubes-repo-templates.noarch                       	4.1.2-1.fc32 
qubes-rpm-oxide.x86_64                            	0.2.5-1.fc32 
qubes-usb-proxy-dom0.noarch                       	1.1.1-1.fc32 
qubes-utils.x86_64                                	4.1.16-1.fc32 
qubes-utils-libs.x86_64                           	4.1.16-1.fc32 
xfce4-settings-qubes.x86_64                       	4.0.5-2.fc32 

Thanks fsflover.

Because Stage 2 failed, I had to upgrade the templates. I had this error: https://github.com/QubesOS/qubes-issues/issues/7251 so I’ve used the fedora snippet from https://github.com/QubesOS/qubes-dist-upgrade/blob/release4.0/scripts/upgrade-template-standalone.sh . After that I could install qubes-template-fedora-36.