Workaround for having Mullvad Browser App Qube

I created a Stand Alone App Qube and installed the FlatPak version of Mullvad Browser.

Then I realized I wanted it to be a temporary, disp Qube, which meant that it must be inside a Template for just a Mullvad Browser.

I also was not thrilled with the note on the Flathub site which said the Flatpak for Mullvad Browser was ‘Unverified” Which was not acceptable to me. For security reasons.

I could try to build a Flatpak: I am guessing I need a computer with a full version of an OS to do that, not a minimalist Qube. Only part of an OS.

I also had thought, that it is likely these install problems might go away, IF, I installed a gnome system onto my Qubes 4.2.1. Which I thought was supposed to be straight forward for me to do. That is to put the Gnome Desktop onto my Qubes machine. ???

Which brings up the question, is the “Gnome Desktop” system considered less secure?
Or was Gnome abandoned because of memory size?

As I have a 64 GB of RAM, I could live with a more memory intensive subsystem. If that is the issue with Gnome Desktop. I think?

There is another option, I could find someway to trust the “Mullvad Browser” flatpak,

Then I could create my StandAlone App Qube with flatpak, Keeping it offline.
Then use that to create brother clones of the Stand Alone Mullvad Browser from Flatpak.

I think it takes up too much time. But I only have to last until someone figures out how to create the correct Template, for Mullvad Browser, which I am guessing may have something to do with we are not using Gnome anymore.

Bring me back to, Is Gnome Desktop less secure? How hard would it be to install?

Also guessing the problem with install might only be in a proxy setting. Something that is set differently for Gnome Desktop. Which Solene once documented. And I have not tried. I have not tried all the options.

Likely, I will try to build a Template Qube which has all the FlatPak subsystem installed.
Add the Snap stuff too.

Then create clones of that to play with other bits of software I might try— that will make those Qubes less secure.

Anyone want to chime in and tell me which avenue of approach is more stupid than another?


You could proceed more easily by:

  • create a new AppVM
  • download the mullvad browser from Mullvad Browser for Linux
  • make an application for it
  • make the AppVM a disposable template
  • create a new disposable based on that AppVM disposable template

done :+1:

1 Like

I need to try that. Felt these issues were going to come up again with other, software.

Noticed: Is it possible to install mullvad browser?

Which has a lingering issue of some kind. Getting finished. No doubt creating a Mullvad Browser Template is correct. Although I usually try to implement with Fedora being the base, not Debian.

Thanks for replying.

the official program is packaged as a tarball containing the web browser as a x86_64 linux binary, it works on most linux distributions because it’s not packaged. It will run fine on debian and fedora

1 Like

This is the way.
It’s what I do in the packaged Mullvad rpm

I never presume to speak for the Qubes team. When I comment in the Forum I speak for myself.

I can extract it.
I can try to start it.

More to research.

by “make an application for it” I meant this App menu shortcut troubleshooting | Qubes OS

The possibility of the documentation not being correct for a later version of Qubes is why you felt that someone should write a recent new documentation.

You were, are correct.

I used to be at a bagel shop in the late afternoon when a group of bicycle racing enthusiasts would gather for their sixty seventy mile training session. I asked one of them how many hours did they work each week to keep their bicycle that clean, and it well functioning. They all had the same attitude.

I never want to work on my bicycle. I pay the bicycle shop to “Tune It” at least twice a week for $70.00 a time. Which was a lot more money back in the nineties.

I want to ride my bicycle, never to do as much as oil the chain.

Obviously, they had a lot more money than myself.

My next problem was when I entered “run program” , “run program as administerator” and nothing happened.