Win10 standalone vm "cannot connect to qrexec agent for 300 seconds"


I use stable edition of qubes for about one year. I have one win10 standalone vm installed with the help of script:

All features regarding safe copy, exchange of files between vm’s worked fine. Usually I have been starting win 10 with qvm-start and qvm-start-gui commands in dom terminal. Today qvm-start results in error "cannot connect to qrexec agent for 300 seconds, see (…) log. Log file is empty. It is possible to use command qvm-start-gui and see for a while that windows booted succesfully but without internet connection and without safe copy and file exchange between vms. After error was shown, windows wm halted.

Please advice what should I check to trace the problem.

Recently Windows had been updated to 20h2 but it work without problems with all features after upgrade, Recently also I have been uninstalled Visual c++ 2017 form Windows installation. I don’t know if it all matters.

Thank You.


I’ve checked that it was possible to use win10 vm after last dom0 update form 16.11.2020. There were no qrexec timeout errors.

I would suggest you follow the following guide which has been working well from many and was updated recently:

Specifically, you may be missing the following:

NOTE: it is recommended to increase the default value of Windows VM’s qrexec_timeout property from 60 (seconds) to, for example, 300. During one of the first reboots after Windows Tools installation Windows user profiles are moved onto the private VM’s virtual disk (private.img) and this operation can take some time. Moving profiles is performed in an early boot phase when qrexec is not yet running, so timeout may occur with the default value. To change the property use this command in dom0:

qvm-prefs -s qrexec_timeout 300

I would suggest you follow these instructions instead:

As I have written, my standalone windows 10 hvm was working fine for about one year without problem and this 300 timeout is already set for one year, as You suggest.

Command ‘qvm-features -D win10 qrexec’ resolves problem, but it results with no internet connection file exchange etc. in windows hvm. Enabling it. by ‘qvm-features win10 qrexec 1’ causes the error back.

Thank You


Restoring uninstalled by mistake Visual C++ from Windows 10 HVM solved error. It restored all needed features that have had gone. Qrexec works.

1 Like

Sorry for the misinterpretation. But I’m happy to hear you managed to solve it!