Win 10 standalone vm seems to have no cdrom drive

  1. Create standalone win10 vm
  2. Within the settings of the VM, boot the VM with windows 10 with iso downloaded from MS and within a fedora vm named ‘download’.
  3. Install windows 10
  4. restart the vm
  5. Use the ‘Qubes device’ applet at top right of dom0 desktop to attach the windows 10 iso
  6. Install xenbus and xenvbd v9.0.0 (i also install 7zip to extract .tar files from xenproject) as described in Documentation : Windows-10 installation on Qubes R4.0 - #6 by scallyob
  7. Windows cannot see the windows 10 iso. When I open file explorer, I can’t see any CD-ROM drive.

Windows 10 VM also cannot see the qubes windows tool iso that I built in another fedora vm, following the instruction at GitHub - tabit-pro/qubes-windows-tools-cross: Qubes Windows Tools build with mingw, wine and qubes-builder

How to make the Windows 10 VM see my .iso in its CD-ROM drive?

the windows 10 vm can see the cd rom after i do the following

  1. set the memory of the windows 10 vm to 4096mb (instead of 2048 mb) in the settings of the vm
  2. start the vm with the qwt iso (that i built) from the dom0 terminal: ‘qvm-start Win10 --cdrom BuildQWT:loop0’
  1. disable hibernation to completely shutdown Windows
powercfg -H off
  1. Make iso available as block device
VM: sudo losetup -f image.iso
  1. Start VM with cdrom param
dom0: qvm-start windows-10 --cdrom VMNAME:loop0