Wifi Works! (after some tshooting) Ethernet still a bust


Thank you in advance for your assistance; I’m relatively new (to running a Linux OS) and currently have Qubes on a new Librem 14 laptop. Migrating completely off of windows is my goal, and between this machine and a standard PureOS Librem 14, the challenge factor is undoubtedly found in the Qubes laptop. The issues I have encountered thus far have been solved, more or less, except for accessing the internet through my ethernet port. Initially, the wifi connection and the ethernet were not functional on this machine. However, after I followed some great advice on this thread Atheros wired Ethernet fails to connect · Issue #7052 · QubesOS/qubes-issues · GitHub the wifi situation resolved itself, gratefully. At this point, I am more than a little stumped. What I would like to avoid, if possible, is reinstalling Qubes. Librem 14’s are not simple machines to mess around with, and although I enjoy diving headfirst into the deep end, drowning isn’t much fun.

Thank you,

Did you enable no strict PCI reset option for PCI Ethernet device?

1 Like

Hey There,

Thank you for the reply. What is PCI reset exactly? And how do I go about enabling “no strict PCI reset”?
I came across this post recently Why enable "no-strict-reset"?, which was a discussion on the subject I found, but there are no instructions as to how to pull it off. Purism Librem 14 v1 - #6 by Sven Based on the June 21st post in the thread here, you are right on the money. The question for me is how to accomplish this.

My many thanks!

You can read about strict reset here:
How to use PCI devices | Qubes OS
How to enable it:
PCI troubleshooting | Qubes OS

You can also configure strict reset directly from the Qubes interface by following these steps:
1. Go to the sys-net VM settings
2. Go to Devices
3. Make sure the device is in the right field
4. Click “Configure strict reset for PCI devices”
5. Select the device, click OK and apply

1 Like