WiFi not showing up

My initial problem

  1. WiFi was working and connected 2 hours ago.
  2. The option to look for WiFi networks does not occur now. WiFi Networks don’t just not show up, the button for what WiFi is around me does not show up.

Chat GPT’s response:
“I am using Qubes OS. I find WiFi is not showing up. Not just WiFi, but the spot to see what networks are available. What do I do? It worked earlier. Ethernet works.”


Text output for search-ability and Vision Assistance Devices

If your WiFi network is not showing up in Qubes OS, it could be due to a few different reasons. Here are some steps you can take to troubleshoot the issue:

  1. Check that the wireless card is recognized by the system: Open a terminal in dom0 and run the command lspci -k. Look for a line that mentions your wireless card. If it’s not listed, your card may not be supported by Qubes OS.

  2. Check that the necessary drivers are installed: Make sure that the drivers for your wireless card are installed in the qube(s) that need to use WiFi. You can check this by opening the qube settings and going to the Devices tab. If your wireless card is listed there, but the driver is not installed, you’ll need to install the driver.

  3. Restart the NetworkManager service: Open a terminal in the qube(s) that need to use WiFi and run the command sudo systemctl restart NetworkManager.service. This will restart the NetworkManager service, which should detect any available WiFi networks.

  4. Check the Qubes Network Manager settings: In the Qubes Network Manager, make sure that WiFi is enabled and that the correct network interface is selected.

  5. Try a different qube: If WiFi is not working in one qube, try connecting from a different qube to see if the issue is with the qube itself.

  6. Check the router: Make sure that your WiFi router is functioning properly and that it is broadcasting the SSID (network name) that you are trying to connect to.

If none of these steps resolve the issue, you may need to seek further assistance or consult the Qubes OS documentation.

My thoughts on proposed answers:

  1. It was recognized 2 hours ago.
  2. It was used 2 hours ago.
  3. I will try that.
  4. I will try that.
  5. I won’t try that. Don’t mess with default configurations as I don’t know what I am doing.
  6. The router worked for everyone else on my campus. As such, I can’t check it.

Notes about AI:

  1. Check ChatGPT will be the equivalent of “just Google It” for Linux Problems.
  2. Every day we grow more dependent upon companies.
  3. Hopefully we will get Natural Language Models that are grown and raised by the community that can be self hosted. It will be like having a mini brain that is both smarter than you and weaker than you at the same time.
For those concerned about me using ChatGPT on the forum
  1. It is in an attempt for me to answer my own problem.
  2. It is labeled as Chat GPT, I am transparent on my sources.
  3. I would otherwise lack the skills to attempt my own answer to my own problem.
  4. In responses to other people’s posts, I would not use ChatGPT. For me to answer my own problems, sure.
  5. The kinds of people that know how to answer these sorts of problems are probably swamped with questions. Using tools to assist with the situation is good.

do you update template or something? include reboot.

I updated something with a GUI interface.

I have rebooted. This did not solve the problem.

I will issue updates upon any changes.

I look at [Dom0] Settings: sys-net to observe what PCI devices are assigned to the sys-net VM. I see these two devices.

00:14.3 Network controller: Intel Corporation
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTLB125 2.5GbE Controller

When I run lspci -k in dom0, I see that both are present.

When I right click networking to click edit connections, I see something labeled Ethernet in bold. I don’t see anything labeled WiFi.

When I click plus I am greeted with another menu. I can “Select the type of connection you wish to create”. When I click WiFi it asks for every possible setting one could be asked for. I was able to fill out what I could think of. Any connection would fail in a way that does not generate an error report.

For hardware options: Bluetooth no, DSL/PPPoE no, Ethernet, InfiniBand, Mobile Broadband, Wi-Fi. A lot of VPN things show up that are not relevant.

what qubes release you use, also what template? what version. have you try changing template to see if other work.

also you can try importing template from qubes installation medium, then reinstall template if changing template doesnt work.

What I said to Chat GPT:
“I found the WiFi card. The WiFi card is both present in lspci -v but is not visible in the UI.”

What ChatGPT said:
If the WiFi card is present in the output of lspci -v, but not visible in the Qubes OS user interface, it’s possible that the NetworkManager service is not detecting the card.

You can try restarting the NetworkManager service by running the command sudo systemctl restart NetworkManager.service in a terminal in the qube(s) that need to use WiFi. This should force NetworkManager to rescan for available network devices, including your WiFi card.

If this doesn’t help, you can try manually configuring the WiFi connection by following these steps:

  1. Open the Qubes VM Manager and select the qube you want to connect to WiFi.
  2. Click the “Create new qube from template” button and select the “StandaloneVM” template.
  3. Enter a name for the new qube, and select “Use existing storage” if you want to share the home directory with the parent qube.
  4. Click “Create” to create the new qube.
  5. Open a terminal in the new qube and run the command sudo qubesctl state.sls qvm.sys-net.
  6. Open the Qubes Network Manager in the new qube and configure your WiFi connection as you would normally.
  7. Once your WiFi connection is configured, shut down the new qube and return to the parent qube.
  8. Open the Qubes VM Manager and select the parent qube.
  9. In the settings for the parent qube, go to the “Networking” tab and select the new qube you just created from the drop-down menu.
  10. Save the settings and start the parent qube.

This should allow you to use your WiFi connection in the parent qube. If you continue to have problems, you may need to seek further assistance or consult the Qubes OS documentation.

Image Proof

What I got out of that:
I think I am making a new network VM?

I am using Qubes OS release 4.1.1 (R4.1).
My template for sys-net is fedora-36-dvm.

Trying other templates would be great. I see fedora’s template. I see a whonix template. I don’t see other options.

Now it is time to talk about the Qubes Installation medium. When I inserted it into the PC, the desktop booted the normal Qubes OS system. I don’t know what went wrong.

Also @51lieal, not ignoring your advice. I am on a laptop on a smaller screen at an odd angle and did not refresh this page recently. I did not attempt that most recent section of advice from ChatGPT.

Idea: Ethernet still works.
I can purchase a WiFi to Ethernet adapter, not bridge.