Wifi dongle not working

Hello everyone,
im trying to use a wifi dongle Brostrend AC3L.

Problem is when i try to install the drivers in my debian template with terminal command :
sh -c ‘wget linux.brostrend.com/install -O /tmp/install && sh /tmp/install’ it says: unable to resolve host adress ‘linux.brostrend.com

Can anyone help me with this please?

Thank you

Use proxy:

https_proxy= http_proxy= wget --secure-protocol=TLSv1_2 linux.brostrend.com/install

Thank you for your answer, it seems that the drivers have installed, but the dongle still not appears when i attach it to my sys net vm, do i have to do anything else after that?
Thank you

Maybe you need newer firmware for your dongle from backports. Check the sys-net-vm log to see if you have some errors when you attach your dongle to this VM.

if i install the driver in sys-net, everything works fine and i can use the dongle, but of course when i restart the computeur, the drivers are gone…
I dont really know what to do now…

The install script is using wget to download packages:

# Download a file from the Internet
download() {
    if is_command wget; then
        re wget --no-check-certificate -nv "$@"
    elif is_command curl; then
        re curl --insecure -O "$@"
    elif is_command busybox; then
        re busybox --no-check-certificate wget -nv "$@"
        die "Please install wget or curl and then re-run the installer"

Add proxy to wget command in install script before you run it in template.

Or you can run this command instead without modifying the install script:
export https_proxy=; export http_proxy=; wget http://linux.brostrend.com/install -O /tmp/install && sh /tmp/install’

Hello, i did try to type your command in the terminal but nothing happened, i also did try to download and after to run the last command you gave me but still nothing happened in the terminal…

i try again and i says: no such file or directory…

i can see 2 files in my folder after the download command, install and install.1 , i dont know if this info can be useful

You can check the file type with file - it should be “POSIX shell
ls -l will show you the size - 19168

If correct this is the install script - it will try to install packages
and download stuff.
For that to work in the template you will need to set the proxy first:

export https_proxy=
export http_proxy=

I would definitely do this in a clone of the standard template.

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.

thank you for the reply, unfortunately i dont understand any of this and i dont know what to do and how to do it all of this looks like chinese to me…

Since you have install script downloaded in template /tmp/install then run these commands:

export https_proxy=
export http_proxy=
sh /tmp/install

i went to terminal and i typed: cd Documents because the script is in this folder then i typed: ```
export https_proxy=
then enter
then export http_proxy=
then i typed sh/ and manually moved the install script.

the install then begins, and finish by saying: wget: unable to resolve host address ‘linux.brostrend.com
Aborting, command failed: wget --no-check-certificate -nv https://linux.brostrend.com/rtl88x2bu-dkms.deb
ERROR: The driver was NOT successfully installed!

Change /path/to/install to the path to your install file in the command below and execute this command:

sed -i "s|re wget|re https_proxy= http_proxy= wget|g" /path/to/install

Then try to execute install again:
sh /path/to/install

this is what i have in the terminal:

sed: -e expression #1, char 89: unknown option to ‘s’

I just give up, this is what is pity with qubes os, you need to be a computer genius to just use a wifi dongle…

Thanks again for your help this is very nice !

Did you copy/paste the command or typed by hand? If you typed it by hand then there should be a typo somewhere.

i did by hand because it is not possible to copy past in the terminal…

You can copy from terminal by selecting the text with mouse and pressing Ctrl+Insert and you can paste into terminal by pressing Shift+Insert.
Or right click in terminal window and copy/paste.

1 Like

how can i copy past your command line to the terminal?