Wifi connection issues with Intel Wi-Fi 6 AX200

Hey

As the title says i have a problem with my wifi connection. My wifi chip is Intel Wi-Fi 6 AX200 Series (802.11ax | 2,4 & 5 GHz | Bluetooth 5.2).

Sometimes the connection works but most of the time it tries to connect but fails, then tries again and fails again.

What i normally do is i reboot sys-net until it works, but is there a solution that works without rebooting?

Have you searched the forum for “AX200” ?
I remember people having problems with AX chips.

https://forum.qubes-os.org/search?q=ax200

Yes i searched for it, but apparently not really good :'D
I will look into the older threads, maybe i will find an answer

Thanks

Try using fedora template, and have you try using 4.1 ?

i’m using 4.1 and fedora for sys-net

Here’s your answer for the AX200:

Hi,
I´d try to update to latest kernel version dom0 and your templates. This usually helps with newer hardware.

Open your terminal in dom0:
$ qubes-dom0-update kernel-latest
$ qubes-dom0-update kernel-latest-qubes-vm

Nope that didn’t help. Now my screen is completely black and qubes unusable as soon as i log in…

If that broke your system just reboot with your regular kernel and remove the previous installs…

Ah okay, I didn’t know this was possible.
How do i do that?

The solution is for qubes 4.0 and debian 10 or fedora 32. Are you sure this would still work on 4.1 with fedora 34?

Worked for me :slight_smile:

Ok. As soon as i fixed my problem with the kernel i will try it :slight_smile:

Did not work for me :confused:
Could you maybe write exactly what you have done?

I’ve never have an issue using ax201 with fedora as sys-net since 4.1 rc, how about reinstall qubes ? is that possible ? if not, try installing, kernel-latest-qubes-vm and fedora-35 from testing repository, and create sys-net based on this fedora 35 template, don’t forget to change this vm kernel in qubes settings.

@51lieal makes a good point. In most cases, that should be automatic, but it might be a good idea to check, just in case.


Failing that, any chance of seeing the output of dmesg in sys-net?

One of the most notorious dances in the Linux kernel is that between the mainline kernel devs and the Intel devs. When one releases an update, the other one usually breaks, and it continues “tit-for-tat” :stuck_out_tongue:

There’s a chance that your iwlwifi kernel drivers are throwing a lot of errors…

In case you don’t know how to do it (or if anyone else sees this post, as the Intel AX series will become more and more common), type this into a sys-net terminal:

sudo dmesg | grep iwl > dmesg.log
#     ^         ^           ^
#     |         |           |
# Show the log  |           |
# ------------- |           |
# Filter out everything     |
# except iwlwifi stuff      |
# ------------------------- |
# Save the filtered stuff to a file called dmesg.log
# ---------------------------------------------------

That will give you a text file of what we need to figure out what is actually happening.
Feel free to redact any information you feel the need to :slight_smile:

1 Like