Wi-Fi not in Settings

So I have Qubes OS installed. I finally figured out how to add “Settings” to sys-net. For internet connections, I have two options: “Wired” or “VPN”. I’ve been able to use ethernet before, but can’t figure out how to get Wi-Fi enabled. Any clues ?

You may be missing drivers for your wireless adapter in sys-net template:

2 Likes

Thanks for the hint, @tzwcfq.

I found some additional information over here: Librem 14 Qubes Users: Which device is for Wifi? - Other OSes - Purism community

Closer, but not there yet.

I found the “Settings” to include the PCI device: “Qualcomm Atheros AR9462 Wireless Network Adapter”. I need to find the driver for this, apparently download it to a USB and copy it over. I found a few versions of this for Windows. I have Fedora and Debian templates currently. There are a lot of crazy looking websites for apparently downloading the driver I need; any clues on a trusted source ? What is the appropriate place to get such a driver ?

If you have Librem 14 notebook then it can be the killswitch problem:

1 Like

I did read about this one and took it into account. Must be close, but not yet.

There already should be drivers for AR9462 in Qubes so it’s not a driver issue.
Maybe you didn’t enable no strict PCI reset option.
Or it a killswitch problem.
I don’t have Framework laptop so I can’t give you any more details about it.

1 Like

Good news. Using this guide, I was able to determine that while I had my PCI device setup in my template, I didn’t have it setup in sys-net. Once enabled in both places, I could then see the Wi-Fi option in sys-net’s Settings. Silly, of course, but being brand new to this environment/OS, I’m still getting my bearings. Thanks, @tzwcfq, for your support, and thanks @Suspicious_Actions for the guide !

1 Like