Why can't I create a disposable appvm like default-dvm

I did a copy of a debian template and named it my-dvm-template and then created based on it a new appvm my-dvm with a disposable template check in its settings.
So far so good right
When I go to the global menu and hit file manager on the my-dvm I don’t get a disposable but instead my regular my-dvm is started.
I know I can create a new appvm based on the my-dvm, but I don’t wanna do that. I wanna create a disposable like the default-dvm.
How do I do that?

If I understand you correctly try:

qvm-features my-dvm appmenus-dispvm 1

From man qvm-features


Generate  menu  entries for starting applications in Disposable VM based on given
AppVM, instead of this AppVM directly.

       Default: create menu entries for AppVM itself

Thanks but I don’t see it did any change to it

Do I understand you correctly that

qvm-prefs mydvm template_for_dispvms True

is already been set?

I did it with gui but yeah I run the checks and it is set true
I created another one and it’s the same

Do you launch the app from the templates or from the apps slide?

The apps slide should launch a dispvm whereas the templates slide should launch the normal AppVM instead.

I can start both template and appvm but the appvm should be like disposable, yet it’s not. I see it with qube manager that it starts my appvm. not the template. and it’s not disposable. and it says YES on the is dvm template column.

Does this launch a DispVM?

qvm-run --dispvm mydvm xterm

yes it does…
why the heck I can’t launch it with menu then???


Those slides in the qubes menu are what I meant.

Which slide did you use form launching the VM?

the apps one

I tried to recreate your issues but for me it works as expected.

The last idea I have is to recreate the app-menue shortscuts. In the applications tab of mydvm’s settings try to refresh the applications.

@uncle_jimmy This might be related to your problem.