Whonix cannot connect to TOR whilst using openvpn as proxy

Mate, I have a problem regarding to WhonixGW16 to TOR when I using openvpn as my proxy, is there anyway to fix this problem?

can you explain this?

Let me say this for the chance. In QubesOS4.1-rc3, I can connect it to tor via openvpn from a qube that provided the network to the thing. However, in QubesOS4.1-rc4, things have gone wrong recently because I have a YubiKey. One thing that I need to mention, this is irrelevant to this conversation, I got my Steam working in 4.1rc4. Back to that topic that I having trouble with is the caution symbol next to the netVM that cannot connect, I don’t know this might be a bug or what, that I don’t know how to fix that thing. If you know how to fix or knowing the bug, might be my computers that included my network. IDK just need to find out WTF is this doing not fine at all or just my ISP blockage.

same config, right?


How are your VMs connected?

For example, a standard Tor connection:

whonix-ws -> whonix-gw -> sys-firewall -> sys-net

Where is your VPN VM? How is yubikey a problem?

Here is my VM coonection:

whonix-ws -> whonix-gw -> OpenProxy -> sys-firewall -> sys-net

I don’t know why your setup stopped working with rc4, but just to confirm… is your VPN configured for TCP through port 443? That’s what Tor uses. Also consider a second firewall VM between whonix-gw and openproxy VM. example:

whonix-ws -> whonix-gw -> firewall2 -> OpenProxy -> sys-firewall -> sys-net

firewall2 can be a clone of sys-firewall. Just clone and drop-in. Double check that all VMs except whonix-ws have “provides network” checked in Qubes Manager settings → advanced tab. Double check that VMs on the left of a given VM in your routing map have the given VM set as the Net VM in Qubes Manager → settings.

1 Like