Whonix 16 upgrade fails with dnf command not found

Tried installing Whonix 16 templates as per How-to: Install the Stable Version of Qubes-Whonix ™ 16

Template download was succesful, templates show up in Qubes Manager

qubesctl state.sls qvm.anon-whonix fails with

ID: template-whonix-ws-16
Function: qvm.template_installed
Name: whonix-ws-16
Result: False
Comment: […] /usr/lib/qubes/qvm-template-repo-query: line 40: dnf: command not found
ERROR: qrexec call ‘qubes.TemplateSearch’ failed

Reboot did not help
Please advise :confused:

PS: No USB devices apart from dom:mic show up, lsusb lists nothing

1 Like

Open up a terminal in your whonix-ws-16 TempateVM and run upgrade-nonroot


For your USB device issue open Qubes Settings for sys-usb, under “Devices” tab check that there is something like “USB controller:…” under Selected. Also strict reset might be needed on some USB controllers.

1 Like

Some updates were downloaded, but not dnf.
I could install it using… apt!?

The four USB controller items are all selected. I didn’t require strict reset so far, are you sure this is the right solution? It really stopped working only after the failed whonix update.

PS: Worked again after a reboot. Reasons unknown.

Thank you. I go try.
I have some problems with whonix too.

                                                                     - Berkeley