Which Wi-Fi adapters work out the box with qubes?

What adapters work out the box with qubes? The kernel on my qubes does not work with Wi-Fi currently, I bought the AWUS036NHA but it doesn’t seem to register/turn on on either of my qubes installations.

I am looking for a Wi-Fi adapter so I can update the kernel which hopefully should allow me to use the inbuilt network card.

Almost there! I have an AWUS036NH without the A at the end and it works with my Fedora 36-based sys-net which handles USB devices as well.

Can you shed some more light on your situation? Do you have the same sys-net configuration as I have? There are lots of potential configuration combinations and we cannot just guess, which one is yours.

Also, if the whole thing is only about updating the kernel, maybe it would be a better idea to use an Ethernet connection for that rather than buying a new antenna.

Yes feels like it!

I just have a standard install of qubes, the sys-net is fedora36.

It looks like this adapter does not work out of the box for my laptop even on windows, so I am going to try a Etherenet to USB-C, see if that works.

One of the only Lenovo laptops it seems without a ethernet port!

Thanks for your reply.

When I plug in AWUS036ACH or a different wireless adapter they do not appear on Devices so there is no way to attach them to sys-net.

Do yours appear on devices like a regular USB stick would?

Yes, for me without any interaction after plugging in the antenna appears in the USB Devices menu and is ready to use with NetworkManager.

Mine does not :(.

We can try diagnosing the issue further. Do you have any spare computer to install Qubes on and then check, if it works there?
Or just download the newer kernel packages from somewhere else, copy them to a USB stick and transfer to dom0 for installation?

Yeah I have tried all the methods listed here on a different qubes system and it doesn’t work there either, so I don’t think its the specific installation itself.

I like the sound of downloading the kernel packages elsewhere and transferring to dom0 and installing, but that seems quite out of my paygrade. Do you know how I might go about that?

Thanks for your reply.

When you’re able, download the latest kernel (as of today it’s this one: https://yum.qubes-os.org/r4.1/current/dom0/fc32/rpm/kernel-5.15.64-1.fc32.qubes.x86_64.rpm) and transfer the RPM to a USB stick.

Once on your laptop, plug the USB stick and see if it’s visible from sys-net's point of view - it should be already mounted and ready to be accessed graphically.

Then from dom0 terminal run the following command (but replace the mountpoint with your actual USB stick mount point):

qvm-run --pass-io sys-net 'cat /run/media/user/mountpoint/kernel-5.15.64-1.fc32.qubes.x86_64.rpm' > kernel-5.15.64-1.fc32.qubes.x86_64.rpm

And at last install it with:

sudo dnf localinstall -y ./kernel-5.15.64-1.fc32.qubes.x86_64.rpm

I have copied it and im installing now.

I have installed it and rebooted - no luck with the Wi-Fi. I did qubes-prefs in dom0 terminal and it says the default_kernel is 5.15.52-1

Glad my guide helped you with the installation despite the initial problems with understanding it.

The other idea I have is to exchange your WiFi adapter with something that is proven to work with Free Software - maybe that’ll help. I have such an adapter somewhere in a shelf but not with me right now - if you want, just ping me/DM me tomorrow and I’ll check it’s details. And since it goes unused for me, I can even send it to you via post office as a gift.

1 Like

The default kernel is not the same as the one I installed, maybe that’s why it’s not working? Though the difference is 5.15.52 to 5.15.64 …
Do I not need to switch sys-net over to 5.15.64? As this guy said:

[Framework Laptop 12th gen (Alder Lake)]

In Qubes-Manager there is not an option to choose the kernel that was just installed, only 5.15.52-1. I just tried to reinstall it but it says the package is already installed. How do I change to it?

Yes please mate, let me know what one it is and I will order it myself! Is there a list of WiFi adapters that are like that? Thanks for the offer!

Whoa, I thought it was going to be much, much older, so there would be a distinction in the minor release.
As of this information… I don’t think that’ll make much difference.

Once of the WiFi cards “certified” to work with distros certified by Free Software Foundation is Qualcomm Atheros AR9285.

If you order it and it will not work, then I have no idea, what’s going on here.

Ok, thanks for your help anyway! I’ll keep researching Wi-Fi adapters. Let me know what model your one is

The thing is… I got enlightened and realized I have one of the FSF-certified machines with me, collecting dust. It’s terribly outdated (it’s a T60 after all) so I don’t use it normally but checked for the WiFi adapter and it was a Qualcomm Atheros AR9285 and that it can connect to my WiFi network.

By saying "certified" with the quotation marks I meant: works for me.

I good luck with ath9k like aronowski . Maybe en:users:drivers:ath9k:products [Linux Wireless] link useful.

Atheros AR9271
This one works for me everywhere in any GNU/Linux version:

In the past I managed to get a similar usb stick to work by manually copying over an older version of the wifi driver + then installing kernel headers.

It consumed a fair bit of time to get it working, and next time around I opted for an internal AR93xx which worked perfectly.

I never resolved this. I just chose a different laptop, too much headache.