Where to install Wifi driver?

I installed Qubes Release 4.0.4-rc1 on on my Lenovo Legion 5P (Ryzen 7 4800H with RTX 2060).

I had to turn on legacy booting and change graphics from discrete to “switching” in the bios (fn-f2 when you boot up)

Without modifying anything I can network by using ethernet connected directly to my router. There is nor wifi available.

The wifi driver for Linux is here (as far as I know). The wifi (on board) is the Intel AX200.

Where do I install a wifi driver? I don’t want to F up my installation by putting it in the wrong place.

Install it in the template used by your network qube.
For the AX200 you may also need to update the kernel used by the network

I have just installed Qubes. I have whatever is the standard setup.

Installing a WiFi driver upon installation must be a common practice. Am I missing something in the documentation?

I think you are talky about Service:sys-net, which has four options including a terminal.

So I guess I have to use that terminal to install it and to update.

On that terminal uname -r gives

4.19.155-1 which I guess is the kernel which may need to be updated.

EDIT: I see that my wifi board requires kernel 5.2 so getting it working is going to take a lot of work. I will do a lot more reading. I found this Qubes discussion on how to update the kernel in the Debian or Fedora VMs.

I will look into this or perhaps try to buy a USB wifi dongle which works with Qubes as is (if such a thing exists).

I am lucky that so much in the Lenovo 5P Ryzen 7 4800h works out of the box. Ethernet interet works as does audio. I can play youtube videos.

You may have missed this in the documentation:

and this:

It’s a fundamental part of Qubes, that for a template based qube, you
have to install software in to the template, otherwise the software will
disappear when the qube is shut down.
This is explained here:

So you need to install the driver in to the template, and (possibly) set
the kernel in the sys-net settings.

1 Like


You may also want to take a look at


sys-net is an AppVM, which gets its root filesystem from another qube (template qube), Fedora, by default. So whenever you want to introduce changes into the root filesystem you have to do it in the latter qube. This is how Qubes’ isolation works.

Hi again,

to follow up on what @fsflover correctly stated, you can attempt loading the 3 .ucode files provided by Intel in the /lib/firmware folder of your sys-net’s Template VM.

Then upgrade your sys-net kernel to v5.8.11-3 or above and add the iwlwifi.disable_rxq=1 referenced to in my previous post.