When i have made excessive adjustments to the settings of fcitx or ibus using a template

In the case of Debian templates, I had been installing software solely through templates, but for the input methods, I ended up installing, removing, and reconfiguring both fcitx and ibus in a messy manner. If I find myself in this situation, would I have no choice but to create a new Debian template or reinstall Qubes OS from scratch?

I tried various things, but even in the untrusted template, I couldn’t get it to work at this stage, and the Hankaku/Zenkaku key would only produce the " ’ " character. I had installed fcitx in the template (there were articles suggesting to use --install-recommends, but…), and now I’m considering configuring fcitx only in the untrusted template.

The documentation contains a how-to page about reinstalling a template:

How to reinstall a template | Qubes OS

Thank you. I tried reinstalling the templates and cubes, but the symptoms remained the same, so I reinstalled QubesOS itself (I could not format the disk, so I finally recommended formatting it on the Windows side),

set locale in the templates, fcitx5, fcitx5-. After installing mozc, I also set the locale setting in qube and configured fcitx5 and was able to use it successfully.

1 Like