What to try next for installation?

I’m trying to install onto a newly installed SSD on a newer Lenovo, and it hangs. It seems like others have gotten this model to work.

I downloaded the installer and verified the ISO. I copied it to a new USB 3.1 flash drive using dd. The Lenovo is set to boot first from the USB drive and it does. I get a bunch of screens with tiny text and the installer says it’s starting. Then it just hangs for about 30 seconds and a cursor comes up which I am able to move around. But nothing else happens, just a black screen.

From the help page, might this apply to my situation? I thought that it would not apply since the drive does boot. “Some laptops cannot read from an external boot device larger than 8GB. If you encounter a black screen when performing an installation from a USB stick, ensure you are using a USB drive less than 8GB, or a partition on that USB less than 8GB and of format FAT32.”

So would I have to try something other than dd? I want to download and copy within Tails and I am not sure if I can get “tools like Rufus, balenaEtcher or the GNOME Disk Utility”.

I have TPM and the absolute persistence module disabled.

what is the laptop model?

it is sudo dd if=Qubes-RX-x86_64.iso of=/dev/sdY status=progress bs=1048576 && sync?

it seem it does not

rufus is windows only
enable administration password and try etcher
GNOME Disk Utility is in tails by default if i’m not wrong

X1 Yoga Gen 6.

it is sudo dd if=Qubes-RX-x86_64.iso of=/dev/sdY status=progress bs=1048576 && sync ?


Thank you.

what cpu?

Intel Core i5 11th Gen

not sure what make the problem (this is anaconda failed to start), but 11th gen cpu have bad compatibility with qubes


Thank you.

Which version have you tried? If it’s 4.0.4, try 4.1-rc2.

I tried 4.0.4. Thank you for the suggestion, I’ll try that.

I downloaded and verified 4.1-rc2 ISO, copied to USB using dd. When I try to boot, it quickly goes to a GNU GRUB command prompt.

Do I have some settings wrong? What can I do from here? This is the same laptop and flash drive as described above.

Try this:

grub> ls # to show all the available partitions
grub> configfile (<Qubes-OS-ISO>)/boot/efi/EFI/qubes/grub.cfg

Replace with the Installer partition. It will most likely be (hd0,1), but every machine is different.

Let us know how you go!

The ls command returns “(hd0) (hd0,msdos1) (hd1)”.

I tried “configfile (hd0)/boot/efi/EFI/qubes/grub.cfg”, “configfile (hd0,msdos1)/boot/efi/EFI/qubes/grub.cfg”, and “configfile (hd1)/boot/efi/EFI/qubes/grub.cfg” but the screen just refreshes to a new prompt. If I turn off the laptop and turn it back on after any of these, it doesn’t do anything differently either.


One of my GPD Win Max notebooks has a Rocket Lake i7-1195G7, and it boots with no issues whatsoever.

@TechExplorer, have you tried release candidate one? That is what I used to boot from, and it worked fine.

Once you install, you can “upgrade” to rc2 through system updates…

The fact that a boot partition exists on your USB stick, but does not continue the boot process any further suggests that:

  • The ISO didn’t get flashed properly (defective USB stick, incorrect parameters when using dd)
  • The hardware is somehow preventing the xen.efi from starting (maybe disable secure boot if it’s on?)

This also suggests that your ISO might not have correctly flashed…

sudo dd if=Qubes-R4.1.0-rc2-x86_64.iso of=/dev/sdY conv=fdatasync status=progress

1 Like

i know


I checked and secure boot is off.

I ran the dd command you suggested. I get the same GNU GRUB prompt when I tried to boot afterwards.

The downloads page doesn’t have 4.1-rc1 any longer. I am not finding it on Github. Do you know where I can get a good copy of it?

Any of the Qubes OS mirrors should have it. Index of /iso/

1 Like

Downloaded, verified, and copied rc1, and I’m getting the same GRUB prompt :disappointed_relieved:

Can you enable legacy boot mode from BIOS? But, to enable legacy boot, it seems that you would need to disable “Kernel DMA Protection” in the “Security” → “Virtualization” menu, as far as I googled it.

I don’t see Legacy mode. I don’t think I have that because it’s a 2021 model :pensive:

“Intel previously announced that in 2020 they are phasing out support for legacy Basic Input/Output System (BIOS) boot mode. This means that many of the Lenovo products launching in 2020 will no longer support the Legacy Boot option in BIOS.”


I just remembered that one of the Qubes OS developers is releasing a weekly build, which includes a newer kernel than the 4.1-rc1 and rc2 build. New hardware requires a new kernel.

So, could you try to download Qubes-20211120-kernel-latest-x86_64.iso from the following link and test it?