What the hell is FUSE, and why is it giving me so many issues?

I’ve done so much troubleshooting trying to do something as simple as installing software and it’s giving me a headache. I’m using Fedora-36.

I created this post a few days ago: How to add application to a qube - #3 by 88uhbvpqboufpcez

I learned that you need to install software on templates, so that you can add the software on a qube-by-qube basis. Armed with this information, I tried to install software properly. I ran into many issues:

  1. I searched the application on the pre-installed software catalog. No results.
  2. I decided to search the software using the PPA (or whatever Fedora uses by default). sudo dnf install <application> does not work because it’s unable to find a match. dnf search <application> finds no results.
  3. I tried installing via a third party repository. Several articles explain what command to use, such as sudo dnf install rpm_file_name but how do I find what the RPM file name is? Some also explain how to use yum, but it’s the same issue…how do I find the path to the RPM file?
  4. After exploring all other methods that I’m aware of, I decided to install the appimage via the website directly. This has been the easiest method to download software so far. Downloading it is no problem. However, when I try to run the AppImage (as many articles explain is the way to run it), I get an error message saying “Cannot mount AppImage, please check your FUSE setup…run it with the --appimage-extract option”. As I explained in my previous post, I didn’t know the full command for that to be useful information. After going through dozens of articles I ran sudo ./file_name.AppImage --appimage-extract and it extracts the files into a squashfs folder. I enter the folder and click on the appname.desktop file and it runs. Now, for application 1, this worked and the application showed up in my Applications tab so I could easily click on it when starting the Qube. For application 2, this didn’t happen, and I was unable to add the application to the Applications tab using any of the known methods described in the Qubes docs and various other forum posts. Okay, so I have to run it manually every time…fine. Not so fine. After running the application and trying to unlock the vault within the application, an error occurred and spit out some details which included: something_something_Fuse.

I’m convinced, whatever issue I’m having, it has something to do with Fuse. What is it, and why is it preventing me from adding applications to the quick menu and preventing me from doing things in the app itself?

Also, in the Fedora-36 template application tab, it says “application missing in template! (gpk-update-view.desktop)”. A user suggested I run cp /usr/share/spplications/xterm.desktop ~/.local/share/applications/footerm.desktop. Not knowing what footerm is, I ran it without changing the command, then also ran it by changing footerm to the name of my application (I’m assuming “spplications” is a mispelling of applications). Same result.

As I explained in my previous post, I followed the Qubes troubleshooting app menu doc: App menu shortcut troubleshooting | Qubes OS

I also made sure to allow executing appimage as program via the chmod command (although it’s much easier to do it in file manager).

I could use some help.

About the fuse error, doing sudo dnf install fuse in the template should fix it.

AppImage can’t appear in the qube menu since they are not installed and they don’t provide a .desktop file. To be able to create one, you need to do the following in the qube where the appimage is:

  • mkdir ~/.local/share/applications
  • nano ~/.local/share/applications/[APPNAME].desktop
  • Paste the following inside and edit the needed values:
    [Desktop Entry]
    Encoding=UTF-8
    Version=1.0
    Type=Application
    Name=[APPNAME]
    Comment=[COMMENT]
    Terminal=false
    Exec=/path/to/the/app/[APPNAME].AppImage
    Icon=/path/to/the/app/icon
    
  • Open qube settings and refresh applications list, it should be listed.
1 Like

Thanks for the reply.

I installed Fuse successfully, and it fixed the issue I was having within the app itself and I’m also able to run app images by simply double-clicking on them. I just wonder why Fuse isn’t installed by default?

I tried the desktop entry method before but I didn’t realize you had to enter the path name next to Exec. That makes sense now. I tried it just now, and finally, the app shows up in Applications. But there’s an issue now…the app won’t start. Here’s what I did in the nano editor:

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
Name=Appname
Comment=Comment
Terminal=false
Exec=/home/user/Documents/appname-1.6.11-x86_64.AppImage
Icon=/home/user/Documents/appname-1.6.11-x86_64.AppImage

I pressed CTRL+O to save in the editor, and pressed ENTER to save the file to /home/user/.local/share/applications/appname.desktop. I verified that it did indeed save to that directory. What went wrong? The appimage itself works, I know because it runs when I click on it manually.

Also, even if this ends up working…why the hell is this so hard? It shouldn’t be this difficult to install some software in Qubes.

My guess is that Fedora as a distribution is very big on having a 100% FOSS base, with all the non-free packages optional by default.

In FUSE, only the Linux kernel parts are licenced under the GPL, while the rest are licenced under a mixture of other restrictive and proprietary licences.

(Yes, the Apache and BSD licences are better than proprietary ones , but I guess that’s not good enough for the Fedora Project…?)

I could be wrong, but this seems to be their mantra with all other aspects of their amazing project.

I agree. I’m watching this closely and paying particular attention to the methodology. Maybe a tool could be made to get Q-Menu entries for AppImages once we have identified a successful method.

2 Likes

Is the issue I’m having here to do with the fact that I’m trying to install via AppImage? I literally can’t install the software anywhere else, as far as I know.

If someone knows an alternative method to install Cryptomator, please let me know.

It shouldn’t be. There shouldn’t be any difference as far as the method of distribution of the software.

You could try the Flatpak if you’re curious, but the end result would likely appear the same to you:


At the end of the day, if you don’t mind opening a terminal inside your AppVM first and then typing in ./cryptomator.appimage, then you’ll at least be able to run it…

…but that’s not the best user experience, and I fully get where you’re coming from.

I just tried to install cryptomator myself with the .desktop file and it works on my side. Make sure you set the correct AppImage name, it should be something like this:

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
Name=Cryptomator
Comment=Multi-platform transparent client-side encryption of your files in the cloud
Terminal=false
Exec=/home/user/Documents/cryptomator-1.6.12-x86_64.AppImage
Icon=/home/user/Documents/cryptomator-1.6.12-x86_64.AppImage

For convenience and for future update, you could change the name to “cryptomator.AppImage” so you can replace the app without messing with the .desktop every time.