What program is best to install into dom0 to view images?

What is the best program to run in dom0 to view images such as screenshots?

1 Like

None. No one serious about Qubes OS would advise you to do that in dom0, otherwise it would already be there. At the end of the day, it’s just Fedora in dom0 if you insist.

1 Like

Copy the screenshot from dom0 to a qubes and view it there - eg in dom0:

qvm-copy-to-vm disp7318 Pictures/Screenshot_2024-01-22*.png

and in disp7318:

eog QubesIncomming/dom0/Screenshot_2024-01-22*.png



this is for viewing when i take a screenshot

i would rather view it using a program than view it by making it the wallpaper

if it’s my screenshot it’s not infected

1 Like

it’s not about the screenshot. It’s about the viewer. Malicious one, some day…


None. View it in an app qube instead.

1 Like

In Qubes OS 4.2, you have a thumbnail in the screenshot tool.

If it’s not enough, you could use nsxiv or sxiv (the former is a newer fork of the latter), they are minimalist picture viewers.

As other said in the thread, dom0 isn’t meant to be used for anything except managing windows and the system.


Qubes OS has GraphicsMagick installed in dom0, you can use it to view and edit images.

gm display image.png


is there a way to associate png files with gm so I can just click on things when I run thunar in dom0? i can associate png files with gm but not gm display.

can i install sxiv in dom0 with sudo dnf install or do I need to get this rpm and then check the hash and move it into dom0 which seems risky?

1 Like

you need to configure xdg-open, see Solene'% : Change default application for xdg-open

you can install sxiv from dom0 if it’s the official repos, don’t worry :slight_smile:


[user@dom0 ~]$ sudo dnf install sxiv
Qubes OS Repository for Dom0 0.0 B/s | 0 B 00:00
Errors during downloading metadata for repository ‘qubes-dom0-cached’:

  • Curl error (37): Couldn’t read a file:// file for file:///var/lib/qubes/updates/repodata/repomd.xml [Couldn’t open file /var/lib/qubes/updates/repodata/repomd.xml]
    Error: Failed to download metadata for repo ‘qubes-dom0-cached’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
    Ignoring repositories: qubes-dom0-cached
    No match for argument: sxiv
    Error: Unable to find a match: sxiv
1 Like

i still don’t know how to do it

am i using the wrong command because it’s dom0?

1 Like

there is a bug currently that should be fixed very soon that prevent the proxy update to work. You can update / install packages at the moment, it’s already fixed in the testing branch though, it should be available within one day or a couple of days.


Hi, I have the same problem and can also not install sxiv. Is there a solution?


For installing in dom0 you use qubes-dom0-update
In this case qubes-dom0-update sxiv will do it.

I never presume to speak for the Qubes team.
When I comment in the Forum I speak for myself.


Hello unman - thank you very much for your help. It installed perfectly:-)

1 Like

this works really well!

1 Like

Thank you very much - and apologies for not having replied sooner.

Best regards