Weird networking issue

I have usual internet->sys-net->-sys-firewall->sys-whonix setup.

I use different browsers, each based on its own template.

Tor browser works as expected through sys-whonix. Other browsers work as expected throufh sys-firewall.

But, all of a sudden, Brave browser dispVMs don’t get to internet through sys-firewall. But, and that is what is weird, it gets to internet when I set sys-whonix as its netVM?!

All other browser dispVM get to internet through the same sys-firewall, so it’s not about sys-firewall?

I have no idea how to track this down, so any suggestion would be highly appreciated.

FWIW, it won’t go online neither when sys-net is set as netVM. Only via sys-whonix?!
If that’s not confusing, I don’t know what is…

My desperate, last bump.

I would probably check whether the issue comes from the dispVM or the browser. Try to ping some well-known IPs from your dispVM (like google’s DNS:, to make sure the qube actually reaches the Internet when connected to sys-firewall.

If not, there probably is an issue with your qube’s configuration, some kind of filtering maybe?

If there is, it’s probably an issue with the browser’s configuration, maybe some kind of proxy?

I have not familiar with whonix, nor brave browser so I won’t be of much more help.

Thanks for the tips!
Well, over sys-firewall, as a test I updated dispVM, and it works. I also installed iputils, and tried ping. And it works either against IP or dns names. Browser still not getting to internet. Disabled all settings in Brave to a bare, unsecured browser, still no luck. Switched to sys-whonix, going to internet via sys-firewall, of course, and it works?!

Weird of the wierdest man…

OK, I’ll create new template and dvm-template, all from the default bare one, and will get back with the outcome…

… and mysteriously all OK after doing that, although I didn’t intentionally did any setting different than already applied to old one…