Weird Display after Backup (debian-11, bionic, arch) *solved

I tried to restore my Qubes 4.1 backup, with my debian-11, bionic and arch template. But now I have got the problem again, that all displays off that vm’s are weird like in the “archlinux template” thread. I already installed the newest testing updates, but unfortunately it doesn’t fix the problem. What can I try to get these templates working again? Reinstall of the complete system with and the template nothing helped me.
Thank you in advance for your help:)

A link would probably help here.

Take a look in the Qubes 4.1 Testing section. There are not much topics. but here is the link;)
it is some problem because of the qubes-core-agent or sth. like that.

So I finally got it working again.
My steps:

  1. I installed my deb11.rpm based on a .rpm deb-11 template from @unman month ago
  2. Then terminal is not working and u have got a black / weird display
  3. Open qubes manager , right click the template and press “open console in qube” . Then a console is starting
  4. login with the username: root and press enter.
  5. Then update the template using sudo apt-get dist-upgrade
  6. Shutdown the vm ,reboot ur Pc and then you should be able to open a terminal like usual
  7. Run sudo apt-get update && sudo apt-get upgrade to get a fully updated vm, with pulse-audio-agent working and after these steps u can update the vm like usual.
  8. Be careful at step 7. if u get asked where to installed the grub, mostly it should be the first one (xda32xxxmb) , press space and okay and it should update :slight_smile:
    I can add my debian11.rpm file. then u just need to copy it to dom0 and run sudo dnf install .rpm and to the steps. otherwise u have to build the template :slight_smile: Do it like u prefer it.
    And of course debian-11 will be realeased the next time and is not yet official supported by Qubes. So if there are any errors it will be fixed soon, but I did not noitce much and daily things are working fine. Even using a microphone in those vm’s works :slight_smile:
    If anybody like to test it just write it and I will send it to you or upload it on github or sth. like that .

Here is how I copy sth. from a vm for example personal to dom0:
run this in dom0 and replace the nameofvm,foldername,username…with yours.
qvm-run --pass-io nameofvm 'cat /foldername/filename.file ’ > /home/username/foldername/nameoffile.file

Stay healthy and enjoy ur week

Ps: The debian-11 template is also available in the itl testing repo, sorry did not know that;) The of course u can install it from the repo and if u have an error follow the steps.
sudo qubes-dom0-update --enablerepo=qubes-templates-itl-testing qubes-template-debian-11
I prefer debian-11 instead of debian-11 because I like to have a new os, which will be available for the next years,working on Qubes 4.1 where I can build my system step by step :slight_smile:

1 Like