Warning: /dev/qubes_dom0/root does not exist

Hi All,

My current Qubes installation is installed on an external WD Passport drive. I mistakenly removed the drive from my Dell laptop before before Qubes completely shut down. Subsequently when I try to boot Qubes, I’m faced with the Dracut Emergency Shell which states:
warning: could not boot
warning: /dev/mapper/qubes_dom0-root does not exist
warning: /dev/qubes_dom0/root does not exist

When I exit the Dracut Shell the following messages appear:

dracut-initqueue[357]: Warning: Not all disk have been found
dracut-initqueue[357]: Warning: You might want to regenerate your initramfs

Any assistance with this issue will be greatly appreciated.

You can check the dracut rdsosreport.txt after dracut timeout and check the exact errors that you’re getting.
You can boot from some LiveUSB (e.g. from Qubes OS installer in rescue mode) and check if your drive partitions are present and not corrupted (try to unencrypt your Qubes OS encrypted LVM partition).

@apparatus thanks for the reply. I’ll give that a try.

**Well after scrolling through the rdsosreport.txt file the only problems I noted were as follows;
dracut-initqueue[361]: PARTIAL MODE. Incomplete logical volumes will be processed.
kernel: device-mapper: table: 253:5: thin: couldn’t open thin internal device
kernel: device-mapper: ioctl: error adding target to table
dracut-initqueue[361]: device-mapper: reload ioctl on (253:3) failed: No data available
dracut-initqueue[361]: PARTIAL MODE. Incomplete logical volumes will be processed.

**then a series of the following messages:

dracut-initqueue[361]:warning: dracut-initqueue timeout - starting timeout scripts

Does anyone have any idea how I move forward in resolving this issue? It appears that all my partitions and volumes are intact.

Are you able to decrypt your Qubes OS LVM partition and mount dom0 root partition successfully?

I’m not sure of the commands to decrypt the Qubes OS LVM partition

1 Like

Thanks @apparatus

I must be doing something wrong or I’m missing a step. When I run the command “sudo cryptsetup open /dev/sdc2 qubes”, I’m asked to enter the pass phrase to the encrypted drive. After inputting the passphrase, I get an error that states “cannot use device /dev/sdc2 which is in use (already mapped or mounted)”

Thanks for the response but this particular article doesn’t actually pertain to my situation. My luks partition is not cloned, I’m connecting the actually external drive (a WD passport drive) that the Qubes OS is installed on to a laptop which is booting a Live Linux Mint CD and I’m trying to access the luks partition from Linux mint when I receive the error mentioned earlier.

Did you try to run:

sudo dmsetup remove_all


sudo cryptsetup open /dev/sdc2 qubes


Yes before and after. No the result is returned when running the command sudo dmsetup remove_all .

Could it be, that the Linux Mint tries to be “smart”/“helpful” in the background and tries to “help” you (by mounting/mapping) things?

– I don’t recall which distro it was … but I’ve had a few “Stop messing up, what I’m trying to do!!”-curses

No I don’t think it’s that because I’ve used other Linux live CD’s and I get the exact same result.

Try to use Qubes OS installer ISO in Rescue mode to be sure.

1 Like

Does it matter what version I use because I don’t remember what version of Qubes I was on. I think it was 4.1

It doesn’t matter.

1 Like