Vt-d iommu bios setting

I have a HP EliteBook 8470p with the i5-3210m cpu how can I enable VT-d?

I can’t find the setting in the BIOS, I can enable VT-x fine though and the cpu should be able to use VT-d.
In addition the HP website shows it uses the Mobile Intel QM77 Express chipset which should also have VT-d capabilities.

Is this an issue with the BIOS or am I missing something?

Did you try to update your bios?

Yes update the BIOS and there this feature will be nested… Also make sure you have enough memory to run Qubes.

I have 8gb of memory and I tried to update the BIOS this morning but couldn’t find the option anywhere, where would it be nested?

@MilkySage …well it is highly recommended that you at least have 16gb of ram to work with. Also to have a functional Qubes environment 32gb + memory is what is needed. I am not saying that 16gb won’t do it but you may have some issues and I wouldn’t have running many domains at the same time. Try to find out what max ram your laptop can have.

You need to go into bios and look around. Manufactures have different layouts. It is usually nested with the other VT option… VT-txt is found I think under security. So basically their are 3 options you need to have. Unfortunately to have all 3 of these options you either need a workstation or server. Desktop/laptos very rarely have all 3. The reason why workstations and servers have the 3 options is because they are built for virtulazation and emulation while desktop and laptops will fall short. Also with such power comes heat buildup and yes power usage. Generally speak also workstations and servers can have 8+ cores X2 and support easily 64gb + memory. So their bios setting/setups are more robust and complex but they will easily support Qubes os environments. It’s not to say that desktop/laptop can’t run qubes-os because their are. But if you want a BEAST that run flawless workstation/server. Remember their are tradeoffs you have to think about.

Max ram is 16 which I’ll get around to at some point, I can’t find the nested settings I can either activate VT-x or nothing. So even though the cpu and chipset are compatible this doesn’t necessarily mean I can use it.

Is that right?

Well to me it appears that you bios is locked down and it may be hidden. Some manufacturers do that. I have a baller gaming laptop ASUS top of the line but even though it states laptop has it I can’t find it. Why, cause it’s locked out and only manufacturer can get to it.
Makes me mad too.

Give it a try. Qubes installer will tell you

Could this be “fixed” by using custom bios like libreboot or coreboot do you think?

Hang on their cause that’s a big can of worms. If the bios is locked you can sure bet other chipsets are too. Plus you need a grounded understanding of hardware before heading off in that direction.

Read the white papers on the chipsets you have not the manufacturer of the laptop. These are two different entities that live in the same house. But one supersides the other. And that is the chip manufacturer

Well, I guess it’s a project for another day then, thanks anyway

This is not how BIOS update works. You need to go to the official website of your manufacturer and find the instructions there. Typically, you need to verify, download it and create a bootable USB stick, which reflashes the BIOS.

I meant I couldn’t find the VT-d option anywhere after updating the bios.

Oh, so the update did not help. It sounds strange. Did you try to ask the vendor about enabling VT-d?


i5-3210m cpu […] should be able to use VT-d.


I was looking at this one. So new question, if I do have the CPU that doesn’t support VT-d, could changing the CPU to one that does solve this issue or would the option still be unavailable due to the BIOS not wanting to recognise the capabilities of a different CPU?

But why would updated BIOS not recognize a compatible CPU option?

Looks like there are at least 2 versions of the CPU, one with VT-d and one without VT-d. Which might be why the BIOS won’t recognise mine, which is why I’m now wondering if this issue can be fixed by replacing the CPU with one that is definitely capable of VT-d.


can be fixed by replacing the CPU with one that is definitely capable of VT-d.

You won’t be able to do that due to your motherboard. The BGA version has Vt-d, the rPGA doesn’t. These sockets are not interchangeable. I ran into a similar issue with the i5-3632QM about a year ago.

1 Like

Of course you could use another rPGA socket CPU with Vt-d.

Yeah, I didn’t mean replace the one I have with the equivalent, I would be looking at one with better performance anyway. But my point was that changing the CPU to one (any one that is compatible) that has VT-d capabilities could solve my issue.

1 Like