VT-d Hardware support is there but qubes say it isn't

Hey Folks,

a few years ago i had installed Qubes on my notebook, but i had too many problems with the Linux world. Now i need more privacy and i am little more familiar with Linux. I have a bit experience with hypervisor through the daily use of HyperV

First i’ve ignored the VT-d error through the Install of Qubes because thought detection failed(HyperV was turned on)

Qubes throwing hardware not supporting VT-d, but that’s not correct


Windoof is garbage, so I’ve tested on my winx64 system:

Disable HyperV:
dism /online /disable-feature /featurename:Microsoft-Hyper-V
bcdedit /set hypervisorlaunchtype off

Runned the Intel® Processor Identification Utility and the virtualization features are active now:
Intel® virtualization technology: Yes
Intel® vt-x with extended page tables: Yes

Cant run a VM inside Qubes without getting the error my Hardware doesn’t support VT-d

Why the heck is this happening? Where i can extract some Logs out of qubes to get more into these problem?

Sorry for asking these questions. I never ask for help because iam a driller. But to be honest, I don’t have the time to drill deeper because I have to suck data to fuck corporations like Facebook. The software that had to be developed also needs manpower. I dont want to lose qubes again because it harmonizes with my philosophy and soul. I want to become part of these idea and movement.

Kind regards,

Have you tried turning VT-d on from BIOS or UEFI?

Some of the remarks that you can find on Hardware Compatibility List can be helpful: https://www.qubes-os.org/hcl/

It could be switching from UEFI to BIOS legacy mode or upgrading bios or kennel.

Thanks for fast reply.

There is no option for enabling VT-d. I have turned on Intel Virtualization technology. There is a entry for VT-x but there is no option for set something only the value „Supported“

Legacy already set and UEFI is newest version available.

For a hardware like yours, there should be an option to enable VT-d in BIOS and UEFI.
Have you checked if there is any option that mentions something about IOMMU?
IOMMU is another jargon for VT-d. You might have missed it.

In UEFI, Advanced -> System Agent Configuration

Maybe there’s the configuration item in there.

1 Like

Thank you so much. System Agent Configuration there is the Option