VMWare Horizon Client

Hello - My work allows access via VMWare Horizon Client. I successfully installed the VMWare Horizon debian client in a debian-based Qube called “Work”

It generally works…except the keyboard input is quite erratic. Sometimes right shift puts in unwanted characters, sometimes a keypress with result in multiple repeat characterssssssssss.

The vMWare Horizon Client works well on my standout debian computer. So, I suspect something is happen in QubesOS? The software only has a couple of settings that can be adjusted and I’ve not had any luck. The only thing I could find on wvware’s site is that “security software” might be interfering withe Horizon client from sending keystrokes.

Anyone have recommendations on how I might troubleshoot this?

There are applications that don’t work well with how mouse and keyboard is used in Qubes OS.

Try reading this thread

ah ok thanks! I’m pretty sure I dont have the tech chops to be making redirection scripts and such as describe in that thread. I’ve been meaning to switch to PS/2 mouse/keyboard so maybe that might fix the problem.

This was a work around for a key-repeat issue on Windows, but you could try it. Add the following to ~/.vmware/config:

mks.disableTypematic = "TRUE"
mks.disableRemoteClientTypematic = "TRUE"



that fixed it lambchop! thanks so much! Wish your answer was a nostr post so I could zap ya some gratitude sats!

1 Like

Well it fixed it…sorta. It fixed the repeat characters issue

I still have random text that gets inserted, particularly around the time I use right shift.

But interestingly, the problem goes away when I use a PS2 keyboard rather than a USB keyboard. Anyone have any ideas on how I might troubleshoot that? Seems the VMWare App is getting weird input from sys-usb?

I’m wondering if this issue has something to do with the following usb-related errors I get when I install the vmware client:

Starting vmware-USBArbitrator … failed
Warning: The daemon for USB redirection fails to start!