VMs based on Fedora-33 launching very slow, "mandb" process takes 80% CPU

Since the Update to Fedora33, the launch of my Qubes based on this template is very very slow!

Looking at the processes, mandb of each Qubes, takes 80% of the cpu?!!

How could we fix this problem?


(sorry for the translation)

renamed the title for (hopefully) more clarity

1 Like

Hi @utopie,
welcome to this Forum.

mandb is a process that indexes the man pages (see mandb). On startup, the OS launches it, or after an OS update, but this process should stop after the end of the index update.

I think that your Fedora 33 based AppVMs update the mandb index, but as its an overlay file-system, on next start, re-update again the index.

I suggest you launch the Fedora33 TemplateVM, and follow the mandb process (with the top command), wait the end of this process. Then restart this TemplateVM and check if it launches again (I think it shouldn’t as the index is up to date… or just a short time). Then relaunch yours Fedora 33 based AppVM, and check.

How to search deeper by yourself? The mandb service, see /etc/sysconfig/man-db, is launched as a service (SERVICE=yes) and as cron (CRON=yes). The index is in the /var/cache/man directory. In mandb man page, I see you can launch it in debug mode (-d).

Note that I don’t see this issue on my Fedora33 AppVM.

Note that you can also do an update of your Fedora 33 TemplateVM, maybe a known issue already solved.


YES !!!

Everything is back to normal. Thank you very much.
Launching the Fedora-33 templateVM solved the problem.

1 Like