Viewing a Remote Desktop From a Qube

When I type “startx” in a vm it fails with the following text:

xauth: file /home/user/.serverauth.1025 does not exist
xauth: file /home/user/.Xauthority does not exist
xauth: file /home/user/.Xauthority does not exist

/usr/libexec/Xorg.wrap: Only console users are allowed to run the X server
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
Couldn’t get a file descriptor referring to the console.

Can anyone tell me how to get to a vm desktop?
Or how to get an installed gui app to run?
(I can’t seem to get remmina gui to appear in the software apps list of my Debian vm/qube)


I’ve spent hours following forum links and can’t find a clear explanation of how to show a remote desktop.
I have a headless remote Debian computer and need to connect to its desktop from my Qubes machine.

I’m not sure to understand what you try to achieve. Here you speak of running a full desktop session into an AppVM? Try for example gnome-session or xfce4-session. Then, you seem to speak of accessing a remote Debian machine from Qubes? Like just connecting to some VNC server?

The last paragraph is my goal: trying to view a remote desktop from one of my qubes.

I can’t seem to get a graphical interface to run: either an entire desktop (where I can run a VNC client) or a VNC client in its own graphical window.

Updated title to reflect this.

Multiple things to unpack here. I don’t think you need to see the qube’s desktop. All you need is to open a VNC application to connect to that remote computer. For installing applications see instructions here. After installing you’ll want to add the installed software to the “qubes menu” by going into “[qube] settings » applications tab” (where [qube] is your qube) and then add the newly installed application onto the qube. If you’re having issues with this last step see here.

Take a look to GitHub - QubesOS-contrib/qubes-remote-desktop.

That’s exactly the opposite of what OP wants.
OP wants to view an external desktop from a qube, not open up a
qube or dom0 to an external viewer.

I’ve used Remmina extensively without any issues - It may depend
on the protocol you are using.

I suggest that you open a terminal in the qube from which you want to
Then start remmina in debug mode - if you are using the main menu
there’s an option to open a debugging window. Otherwise, look at:

As to not getting the item in the apps list, read the documentation:

In this case, I don’t understand the original issue at all and what are the exact troubles. Especially, why startx is wanted.

I checked that Remmina was installed and tried to start it but command line said the command was not found. I’ll have to trouble shoot that. Maybe a PATH issue. And I don’t know where the “remmina” command is located, so I have to find that.
I’ll keep trying.
FYI. I made a standalone qube from my Debian template for this. Could use Fedora if it would be better?..

I have already followed the link to install the app (Remmina in this case) but I couldn’t find it in the list of applications, even after a reboot.
I saw something about creating a “.desktop” file in order to make it appear in the applications tab, but it was too much for me to understand.

Fyi, I mentioned wanting startx because in many ways I am a newb. :slight_smile:
In my frustration I just wanted an interface I could click around on until I found where the Remmina command is.

This should work:

  1. Create a standalone qube based on the Debian-10 template.
  2. Start a terminal in the standalone qube.
  3. Run sudo apt install remmina
  4. Open Qubes Settings for the standalone qube and click on the Applications tab.
  5. Click Refresh Applications
  6. Select Remmina from the Available list and click > to move it to the Selected list.
  7. Click Ok
  8. Remmina will now appear in the menu for your standalone qube.
1 Like

On Debian, the program is installed at /usr/bin, and is called
That should be available to your PATH.

I did all that already … BUT, I just did it again and this time it downloaded and installed a lot more than it did the first time! Everything went smooth after that. Thanks!
Makes me wonder what I actually installed the first time, LOL.

And unman, thanks too. I knew it “should” be in my PATH, but I was in the “dazed and confused” part of my journey. Glad to be clear of it now!

Qubes OS can be a bit overwhelming at first - there is a lot to get your head around compared to a regular Linux distribution. I know it took me a few weeks of reading the documentation, hanging out here and just trying stuff out before I got to grips with it.

1 Like