Various suspend problems

There are different problems regarding suspend in qubes. While trying solve mine, I got the impression, people had problems to find their specific issue and subsequently the right solution. Thats why we should collect the solutions here according to the system/platform.

Lets start …

Intel 11th Systems - Currently no solution, see Support for Intel Tiger Lake Processors · Issue #6411 · QubesOS/qubes-issues · GitHub

Also it seems R4.1 in general has problems. Solutions?

1 Like

With Xen 4.14 (thus R4.1) there is a general problem regarding suspend/resume which seems almost solved for intel <=10th gen platforms. As workaround you can disable hyperthreading in BIOS or (re)enable it in xen by adding smt=on to xen options in grub. See Resume from suspending is broken after update to Xen 4.14 · Issue #6066 · QubesOS/qubes-issues · GitHub

For Ryzen (4700, 5700 and 5850 confirmed, but probably all) that workaround does not help. It’s (probably) a different bug/issue, see PVH VMs does not start after resume · Issue #6859 · QubesOS/qubes-issues · GitHub


@BigQ Thank you for pointing to the Github hyperthreading solution! Stumbling upon this thread means I can finally suspend my laptop after upgrading months ago to 4.1. I have only been able to sleep since then. But now suspend works again and I can close the lid!

1 Like

@BigQ this solved the suspend problem on my Dell Precision 5520 with 7th Gen Xeon. I disabled hyper-threading in bios. additionally I had to disable Trusted Execution in bios to allow hyper-threading to be disabled on my Dell.

Many Thanks

1 Like

for my x230, disabling hyper-threading in the bios solved the issue that it wouldn’t go into proper suspend, and then not wake up.

Great to see that I could help!