Using thinkpad webcam in qubes+vm?

I have an integrated webcam. I can detect it via the terminal but it doesnt appear inn the usb attachment tool. I want to use the webcam in a windows virtual machine inside of qubes. I tried going to “device manager” in qube settings and moving some usb and other devices to the vm but it either doesnt attach the webcam or it doesnt let me boot the vm.
How can I get this webcam detected?. My thinkpad is supported by qubes.
Also inn cheese no device is detected.

It could be that you have USB keyboard/touchpad and tour webcam is connected to the same USB controller as them. Because of it this USB controller didn’t get attached to your sys-usb qube during Qubes installation.
To check whatever you have USB keyboard or not run this command in dom0:
If it’s a USB keyboard then you still can attache this USB controller to sys-usb and then pass keyboard/mouse to dom0 and attach your webcam to other qubes but there will be security issues with this:

I think i deleted sys-usb from qubes manager when i was learning. Can i restore it?

Yes, read the second link in my previous post. But you need to figure out whatever you have USB keyboard or PS/2 keyboard first.

1 Like

I see “virtual core pointer” and some devices + “virtual core keyboard” along with intigrated camera and some other stuff.

Actually i started the usb qube after restoring and it appears inn the tool box but it fails to add to windows vm. It works if i attach it to other vm like fedora. When i attach to windows i get a failure with qrexec not connected as the final string. How to fix

For Windows VMs you can install Qubes Windows Tools:
Contents/ at master · Qubes-Community/Contents · GitHub
But if you don’t want to install QWT and you only need USB then you can do it with this:
Windows USB integration with R4.1

1 Like

It worked thanks but it seems to have caused an issue with whonix/tor. Im unable to start tor at all. It gets stuck at like 2%/10%. Diff bridge types dont work. I tried turning off sys usb and tried qvm features for dom0 after enabling it for win vm. Is thdre something i did wrong?

The USB webcam attachment shouldn’t be able to cause his problem.
Did you try custom bridges from

1 Like

Thanks it was a modem problem. Your solutions helped a bunch. Im keeping my bitcoin safe and require photos for coinbase. Thanks