Using modprobe to amend system kernel


Presently on my second install of qubes 4.2. First one was more of a dummy run to get a feel for how things worked. Prior to this I had dicked around for a bit in virtualbo before concluding that if I were to give linux a proper go I would need to stop having a windows install easily to hand in times of crisis.

Anyway my first install failed when I bought a ps2 keyboard and tried to set up a usb-sys. Nbd I remember thinking, I wanted to start over anyway. But since then I have been singularly unable to get the bastard thing to properly reinstall. According to the threads on here it could be a great many things my cpu (upgraded from an am4 3600 to a 5700x today), or even the drive I am installing it on having errant data from a previous install (today I installed a brand new never been used before 512gb m.2 to go alongside the 2tb one that qubes was installed on last time.

When it has previously hung on install it has typically been broadly at the end of the install process. But until today had figured I’d just needed a new hard drive (I’d actually had 4 nvme cards on a pci riser forma few weeks but couldn’t work out how to make bifurcation work, so they’d sat there inside the machine but unused until today when I finally got my arsenal until gear (also upgraded the cpu as previously mentioned and the Heatsink from a wraith to a peerless assassin). Also managed to remove the stock 128gb nvme card today after roinding the thread

So the net result is that I’m Presently here without any devices other than my phone. And I don’t really gave a lot of linux knowledge either, nor windows tbh. I know more than most people my age but I’ll never be tyrell wellick or Sam sepiol level.

Anyway, yodays install seemed to be going swimmingly. I disabled smt in the bios like a thread on here suggested, but wasnt going to remove the new cpu upon hearing that there might be some problems. It sailed through the install right yo the end and then bam! I got a popup saying…

[Dom0] Error (on dom0)
[‘usr/bin/qvm-start’, ‘sys-firewall’] failed:
stderr: "Start failed : internal error Unknown PCI header type ‘127 for device
0000:06:00.0’, see /var/log/libvirt/libxl/libxl-driver.log for details

So I did some googling found another thread on hear talking about the same issue being resolved by him installingb4.2 instead of 4.1. And I didn’t really understand what hecwas bangingnon about anyway. Then I found another website talking about how this error is something to do with my gpu spaccing out and needing to be reset.

And this other website seemed to have a fix but they didn’t really go into detail about how I should do it. I mean they say it can be done without rebooting, but given mouse is all frozen ip I’ll be dammed if I can work out how to do it. And like I say, my laptops out of action too, presently wonder if ibcan use a portable version of rufus so as to create a w11 iso so I’m not trying to work out howvyo do this on my bastard phone.

Tl:Dr- how do I do what it says on here to do?

I guess what I’m wondering is whether I should use a ‘try it’ linux install from ubuntu maybe. Then use thst access the files on the USB iso I am presently trying to install. But then, given the qubes iso is dd written, surely I’d need to redownload a fresh copy and amend and verify that bnd_ ddress? Which, given the github thing says no need to reboot it just makes me wonder ifvim misunderstanding

It’s probably a problem with PCI network controller attached to sys-net.
Maybe you can try to fix it like this:

You can also try to install Qubes OS 4.2 with kernel-latest (there is a separate GRUB menu entry for this in Qubes OS installer). Maybe it’s a problem with your network controller driver that could be fixed in newer kernel version.

Thanks dude. I actually have on board Etherley but u thinking it might be nothing to do with the gpu but another card has reminded me that I have a 2-port usb 3.2 card installed. Will within that out too.

Am using an rog strix b450 so the network chipset on that is inelt it11-at. Although TBf I have been considering installing a backup given the onboardvone sometimes craps out.

Appreciate you taking the time to read and reply. I can ve rather garralous at the best of times but when I’m half cut I’m like the energizer bunny. I just keep on going and going!