Using Atheros (ath9k) USB WiFi dongle freezes sys-net (sometimes dom0 too)


I have been experiencing this ever since I started using Qubes OS (4.1). Even with today’s up-to-date system and templates, I still see it.

I plug the Atheros (ath9k) USB WiFi dongle (TPLink TL-WN722N) and after loading it with some traffic (e.g. 10-20 Mbps), sys-net becomes unresponsive and networking stops. Sometimes even dom0 cannot kill sys-net. I have noticed on some occasions that even dom0 becomes unresponsive in such situations, then a hard reset is the only way out of it. I can’t find an exact pattern of which happens when but the fact is that it doesn’t work as expected.

The same WiFi dongle works flawlessly on my regular Linux systems.

On Qubes OS Internet through Ethernet works fine. Other (non-ath9k) USB WiFi dongle I tested worked fine too. The USB port is not the issue - I tried them all and other devices work fine on all ports.

Has anyone experienced this and what is the fix?

Which Template are you using for sys-net? Did you try another one?


Initially (when I “met” Qubes OS) it was fedora-36.
Then fedora-37.
Then fedora-37-xfce.
Currently - fedora-38-xfce.

No, I haven’t tried another (e.g. debian) one. I have the debian-12-minimal installed but perhaps it is not suitable.

My concern is that this is probably kernel-related (perhaps even Xen related) and IIUC all templates use the same kernel by default. I am not sure what might happen if I use the one “provided by qube”, so I didn’t dare to touch. I also found this unresolved issue but I don’t know if it is related.

So, I wonder what to do.

The Issue looks closed to me. I guess you should ask to open it again and provide some logs there.