Use Microsoft Sculpt wireless keyboard with Qubes OS

I want to use my Microsoft Sculpt wireless keyboard and mouse with Qubes OS. When I plug in the USB dongle I used to get the notification that Keyboard access was denied. I could however use the mouse just fine. I followed the instructions on the Qubes documentation to allow USB keyboard usage. After doing that and restarting my machine I no longer get the Keyboard access denied message when I plug in the dongle but I still cannot use the keyboard, only the mouse. Can anyone help?

  1. Are you in R4.0?
  2. In sys-usb is the package qubes-input-proxy-sender installed (most likely yes, since your mouse works)
  3. In dom0 what is the contents of your /etc/qubes-rpc/policy/qubes.InputKeyboard?

You want it to be like this:

sys-usb  dom0   ask,default_target=dom0
$anyvm   $anyvm deny

(Post typed on a M$ Sculpt wireless keyboard under Qubes R4.0 :wink:

1 Like
  1. I’m on 4.1

  2. Yes, it’s installed

  3. It used to be

    sys-usb dom0 ask,default_target=dom0

    I changed it to

    sys-usb  dom0   ask,default_target=dom0
    $anyvm   $anyvm deny

    and restarted my laptop but that does not seem to have an effect.

R4.1 has a changed policy system I haven’t worked with yet.

I understand you now have to look under /etc/qubes/policy.d/

I’m still on R4.0 so I have no experience with it yet.

Yes - in 4.1 there are policy files are in /etc/qubes/policy.d/.
Qubes ships a default file in 90-default.policy, which contains most
of the default policy settings.
If you want to change a policy, you create a new lower numbered file - e.g.
30-user.policy, and write your new policy there.

That said, there are still policy files under /etc/qubes-rpc/policy, and
the InputMouse and InputKeyboard files are there.
The line you’ve quoted looks right to me, but I don’t have the bash
shebang at all.
Try it with sys-usb dom0 allow - you shouldn’t need to restart the
laptop, although it wont hurt.

I changed the contents of /etc/qubes-rpc/policy/qubes.InputKeyboard to be just the single line sys-usb dom0 allow. This didn’t seem to have any effect immediatley, so I restart my laptop. When being asked for my disk encryption password I could successfully enter that using the USB keyboard. However, once I reached the login screen typing on the USB keyboard no longer had any effect.

I’m using Qubes with KDE. Could that be the source of the issue? Is there anything I have to change in the KDE settings to make the keyboard be recognized?

You could check by selecting Xfce at the login, but I doubt this is the
Is the keyboard recognised in sys-usb?
If you open a terminal in sys-usb, can you type there with the keyboard?

Typing in the sys-usb terminal does work indeed…

Switching to Xfce did not have any effect.