USB SSD enclosure freeze at GRUB

I recycled my old 256GB samsung 970 plus nvme ssd on a usb 3 external enclosure.

I installed qubesOS Qubes-R4.2.0-rc1-x86_64 on it.

No problem during the installation.

I can boot it up to grub, but whatever I do on grub, c, e or enter just make it freeze forever.

PC is a custom built tower:
ASUS x470 prime
AMD ryzen 5 2600
RTX 3060
Win 11 as primary OS
Qubesos boot from SSD external enclosure(Chipset RTL9210B) on USB 3.2 port.
I think they call that a USB Attached SCSI.

using qubes in external ssd has no issue for me, not sure with the nvme enclosure, if you want, you can shrink space 50gb in the windows, and try installing qubes there. perhaps its not caused by the enclosure but the pc itself ? not really sure, just test it

Its not the first time I run QubesOS on this PC. I regularly used it on internal nvme for 2 years. The only thing that is new is the RTX3060.
I deleted everything and now I want to use it on external portable SSD.

At least you confirm its possible to use it on external ssd.

Maybe its related to the fact its an enclosure.
I think it might mess with xen or grub. I don’t know.

should be because of the rtx too, what if the vga / hdmi cable is attached to the mainboard, not the gpu?

I can try but I doubt it can do anything.
My cpu is not an apu, there’s no gpu on it.

Maybe the fact it’s a RTX plays. I will read on that.

What confuse me is the fact its a total freeze whenever I press a key or just let grub lunch an entry automatically.

Is there any logs with grub?

I spent my whole Saturday trying to resolve the issue.

I chroot into dom0-root from a fedora live os from virtualbox to update grub.
I added
nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off

still the same problem.