USB passthrough not working

Possibly related to this:

I can’t comment in that thread since I’m not on the testing team, but I noticed that sys-usb no longer allows passthrough of inputs. On a fresh installation (updated) I tried editing /etc/qubes-rpc/policy/qubes.InputKeyboard and its mouse counterpart as per the documentation but it didn’t work.

I tried the sudo qubesctl state.sls qvm.usb-keyboard but it also didn’t work.

My USB input devices work fine even for LUKS until a sys-usb is started. (The fresh installation didn’t come with a sys-usb, by the way.) The input device notifications appear but the devices are unresponsive. Shutting down sys-usb doesn’t bring the devices back.

For reference I use a debian-11-minimal with only the following modifications:

  1. qubes-usb-proxy installed

  2. The usb controller attached with no strict reset set to ‘true’

  3. Meminfo_writer off

  4. Kernelopts set to include ‘iommu=soft swiotlb=8192’.

Any input (pun totally intended) would be greatly appreciated.

:drum: :cd:

Just checking the obvious. You’re not using the unstable repo, right?

I’m adventurous but not suicidal, so no

I’ve reinstalling my laptop a week ago using 4.1 stable in qubes homepage, update everything to latest in current-testing repo, and configure sys-usb, and everything still work as expected.

I think you missing qubes-input-proxy-sender try install it.

I’d love to try (I think it’s the right answer), but the new qrexec overhaul has me spinning in circles right now