Usb-keyborad and usb-mouse stop working in the middle of update to 4.2

I’m in the middle of update to 4.2. I does first 3 stages, and reboot the system. My sys-usb stops handling my mouse and keyboard. I was able to login with qubes.skip_autostart kernel option. I tried to recreate sys-usb using qubesctl state.sls qvm.usb-keyboard but it still doesn’t work.

P.S. I can’t also continue dist upgrade because of some connection issue “Curl error (56)”. I’m trying fixing that by changing Update-Proxy policies and updatevm but can’t find the solution.

in /etc/qubes-rpc/policy/ I only have qubes.InputKeyboard.rpmsave and qubes.InputMouse.rpmsave
insted of oldstyle policy files without rpmsave extension. They both have right rules at he top.

@unman can you point me in some direction here?

I think you can create /etc/qubes/policy.d/50-config-input.policy and put the following lines in it:

qubes.InputMouse * sys-usb dom0 allow
qubes.InputKeyboard * sys-usb dom0 ask default_target=dom0

I found out, that I have such files but for some unclear for my reason with such contents:

sys-usb dom0 allow
qubes.InputMouse * sys-usb dom0 ask default_target=dom0
qubes.InputKeyboard * sys-usb dom0 deny
#not configurable by this state
qubes.InputTablet * sys-usb dom0 deny

which shows syntax error in policy editor.

I think you can try removing the first line and modify the next two lines ( otherwise you’ll still not be able to input with your devices).

1 Like

Yes, I do that and now it works. Don’t know why I got that garbage in policy file and why it works on 4.1.

1 Like

Probably due to dist-upgrader bugs. Best to report them to github.

Please search on github for this issue and report if you are the first to face it. It will help others.

1 Like